summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblu2562018-07-21 00:58:08 +0300
committerblu2562018-07-21 00:58:08 +0300
commit0060f35d0cfd7e9066f139e4d6d1a33ffb3d2c32 (patch)
tree1e4473c2763badbb67d9f088644427def4e28229
downloadaur-0060f35d0cfd7e9066f139e4d6d1a33ffb3d2c32.tar.gz
Uploaded PKGBUILD
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD64
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0152b22ef2f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wmsolar-git
+ pkgdesc = A dockapp depicting the solar system (90 deg. heliocentric)
+ pkgver = r2.37b9014
+ pkgrel = 1
+ url = https://github.com/engerim42/wmsolar
+ arch = i386
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = make
+ makedepends = ed
+ depends = libxpm
+ depends = gcc-libs
+ provides = wmsolar
+ source = wmsolar-git::git+https://github.com/engerim42/wmsolar
+ md5sums = SKIP
+
+pkgname = wmsolar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e6779596b05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: blu256 <mfilippos@yandex.ru>
+
+pkgname=wmsolar-git
+pkgver=r2.37b9014
+pkgrel=1
+pkgdesc="A dockapp depicting the solar system (90 deg. heliocentric)"
+url=""https://github.com/engerim42/wmsolar
+license=('GPL')
+arch=('i386' 'x86_64')
+depends=('libxpm' 'gcc-libs')
+makedepends=('git' 'make' 'ed')
+provides=('wmsolar')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ # The following because we need to use an older C++ standard
+ ed Makefile <<EOF
+38c
+ install -c -s -m 0755 wmSolar \$(DESTDIR)/usr/bin/
+.
+2c
+CFLAGS = -O2 -Wall -std=c++03
+.
+w Makefile
+q
+EOF
+
+ # The following edits in Lunar.h and PlanetData.cpp
+ # fix an error when trying to initialize a double
+ # floating point constant in-class.
+ ed Lunar.h <<EOF
+66c
+ static const double SYNODIC_MONTH;
+.
+w Lunar.h
+q
+EOF
+ ed PlanetData.cpp <<EOF
+20a
+const double Lunar::SYNODIC_MONTH = 29.530588861;
+
+.
+w PlanetData.cpp
+q
+EOF
+
+ # At last, build it!
+ make all
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ make DESTDIR="$pkgdir/" install
+ echo 'Warning: the executable is called wmSolar.'
+}