summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Smith2018-04-06 16:23:02 -0500
committerJames Smith2018-06-12 14:43:06 -0500
commitf66dac50c6ad06d55d339d777ad1071e16551532 (patch)
tree271ce1d1d7ed3aff1e419144a42a63eda18b8784
downloadaur-f66dac50c6ad06d55d339d777ad1071e16551532.tar.gz
Added PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..002494cc97f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wmvolman
+ pkgdesc = Dockapp to automount external disks with udisks2
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/raorn/wmvolman
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL2
+ makedepends = glib2
+ makedepends = pkg-config
+ depends = udisks2
+ depends = libdockapp
+ source = wmvolman-2.0.1.tar.gz::https://github.com/raorn/wmvolman/archive/2.0.1.tar.gz
+ sha256sums = 625c2911fd296dd4ce021f7902e64162544d75bd948145fc015cca8546b728ad
+
+pkgname = wmvolman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d41d5a5bab09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: James Smith <jsubuntuxp AT gmail DOT com>
+pkgname=wmvolman
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Dockapp to automount external disks with udisks2"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/raorn/wmvolman"
+license=('GPL2')
+depends=('udisks2' 'libdockapp')
+makedepends=('glib2' 'pkg-config')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('625c2911fd296dd4ce021f7902e64162544d75bd948145fc015cca8546b728ad')
+
+# Manually generate configure
+build() {
+ cd "$pkgname-$pkgver"
+ aclocal
+ autoheader
+ automake --add-missing
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}