summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 23:13:30 -0600
committerBrian Bidulock2015-06-10 23:13:30 -0600
commit2520abd24b3ba3d7ea44f4cdf842149b2f68969a (patch)
tree00fb95553a4956321c34192712ac7781f5929598
downloadaur-2520abd24b3ba3d7ea44f4cdf842149b2f68969a.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faae49356bfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wmweather+
+ pkgdesc = Downloads the National Weather Service METAR bulletins, ANV and MRF forecasts, and any weather map for display in a WindowMaker dockapp
+ pkgver = 2.15
+ pkgrel = 1
+ url = http://sourceforge.net/projects/wmweatherplus
+ arch = i686
+ arch = x86_64
+ groups = x11
+ license = GPL
+ depends = pcre
+ depends = libxpm
+ depends = curl
+ depends = windowmaker
+ source = http://downloads.sf.net/wmweatherplus/wmweather+-2.15.tar.gz
+ md5sums = 5eea25d708abe1da3549672b898bd0d4
+
+pkgname = wmweather+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ae3843271d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: lspci <agm2819 at gmail dot com>
+# Contributor: Mario Blättermann <mariobl@gnome.org>
+
+pkgname=wmweather+
+pkgver=2.15
+pkgrel=1
+pkgdesc="Downloads the National Weather Service METAR bulletins, ANV and MRF forecasts, and any weather map for display in a WindowMaker dockapp"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/wmweatherplus"
+license=('GPL')
+groups=('x11')
+depends=('pcre' 'libxpm' 'curl' 'windowmaker')
+source=("http://downloads.sf.net/wmweatherplus/$pkgname-$pkgver.tar.gz")
+md5sums=('5eea25d708abe1da3549672b898bd0d4')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}