summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-12-01 18:14:37 -0700
committerBrian Bidulock2015-12-01 18:14:37 -0700
commit4b25d51ad4439f16daf92ef0039235d1e0dccecc (patch)
tree1b74241ce0d1f776d7827f98dff8cbe859881594
downloadaur-4b25d51ad4439f16daf92ef0039235d1e0dccecc.tar.gz
initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7b9f856568a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v7
+# Wed Dec 2 01:14:36 UTC 2015
+pkgbase = wmweather+-git
+ pkgdesc = Downloads the National Weather Service METAR bulletins, ANV and MRF forecasts, and any weather map for display in a WindowMaker dockapp
+ pkgver = r72.98823ac
+ pkgrel = 1
+ url = http://sourceforge.net/projects/wmweatherplus
+ arch = i686
+ arch = x86_64
+ groups = x11
+ license = GPL
+ makedepends = git
+ depends = pcre
+ depends = libxpm
+ depends = curl
+ depends = windowmaker-crm-git
+ provides = wmweather+
+ conflicts = wmweather+
+ source = wmweather+-git::git://git.code.sf.net/p/wmweatherplus/git
+ md5sums = SKIP
+
+pkgname = wmweather+-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8103f778a6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: lspci <agm2819 at gmail dot com>
+# Contributor: Mario Blättermann <mariobl@gnome.org>
+
+pkgname=wmweather+-git
+_pkgname=wmweather+
+pkgver=r72.98823ac
+pkgrel=1
+pkgdesc="Downloads the National Weather Service METAR bulletins, ANV and MRF forecasts, and any weather map for display in a WindowMaker dockapp"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/wmweatherplus"
+license=('GPL')
+groups=('x11')
+depends=('pcre' 'libxpm' 'curl' 'windowmaker-crm-git')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+makedepends=('git')
+source=("http://downloads.sf.net/wmweatherplus/$pkgname-$pkgver.tar.gz")
+md5sums=('5eea25d708abe1da3549672b898bd0d4')
+source=("$pkgname::git://git.code.sf.net/p/wmweatherplus/git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $pkgname
+ autoreconf -fiv
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr
+ make V=0
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}