summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-23 09:33:41 +0800
committerzxp198210052024-01-23 09:33:41 +0800
commit2f96adf18901a3db1c179226e32a0e62a5e1c229 (patch)
tree0b285e65bf486fb876de6911a6c424c1ee1ec9cf
parent8c258e8785342ca7891ea2f5316376a84b1a0db8 (diff)
downloadaur-2f96adf18901a3db1c179226e32a0e62a5e1c229.tar.gz
update to 1.30.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c809577e927..c100770e8de6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = wnr-bin
pkgdesc = Work/Rest Timer. Stricter. Prettier. More features.
- pkgver = 1.30.1
- pkgrel = 5
+ pkgver = 1.30.2
+ pkgrel = 1
url = https://getwnr.com/
arch = x86_64
- license = MPL2
+ license = LicenseRef-MPL2
makedepends = squashfuse
depends = electron22
- depends = hicolor-icon-theme
depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- provides = wnr-1.30.1
+ provides = wnr-1.30.2
conflicts = wnr
- source = wnr-1.30.1.AppImage::https://github.com/RoderickQiu/wnr/releases/download/v1.30.1/wnr-1.30.1-Linux.AppImage
- source = LICENSE-1.30.1::https://raw.githubusercontent.com/RoderickQiu/wnr/v1.30.1/LICENSE
+ source = wnr-1.30.2.AppImage::https://github.com/RoderickQiu/wnr/releases/download/v1.30.2/wnr-1.30.2-Linux.AppImage
+ source = LICENSE-1.30.2::https://raw.githubusercontent.com/RoderickQiu/wnr/v1.30.2/LICENSE
source = wnr.sh
- sha256sums = 148d7ef576a0af05b416ee05a82f5e63caca3136bd603e00a3a568f96b8f8e9c
+ sha256sums = fd774a07fb28950878f3560542157a7335e816fe0b5db908bafbdbda42e58b4c
sha256sums = 1f256ecad192880510e84ad60474eab7589218784b9a50bc7ceee34c2b91f1d5
sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
diff --git a/PKGBUILD b/PKGBUILD
index bd537e493322..e9836b32b163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=wnr-bin
-pkgver=1.30.1
+pkgver=1.30.2
_electronversion=22
-pkgrel=5
+pkgrel=1
pkgdesc="Work/Rest Timer. Stricter. Prettier. More features. "
arch=('x86_64')
url="https://getwnr.com/"
_ghurl="https://github.com/RoderickQiu/wnr"
-license=('MPL2')
+license=('LicenseRef-MPL2')
provides=("${pkgname%-bin}-${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'hicolor-icon-theme'
'dbus-glib'
'libdbusmenu-glib'
'gtk2'
@@ -25,7 +24,7 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/RoderickQiu/wnr/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('148d7ef576a0af05b416ee05a82f5e63caca3136bd603e00a3a568f96b8f8e9c'
+sha256sums=('fd774a07fb28950878f3560542157a7335e816fe0b5db908bafbdbda42e58b4c'
'1f256ecad192880510e84ad60474eab7589218784b9a50bc7ceee34c2b91f1d5'
'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
@@ -36,6 +35,7 @@ build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"