summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Franc2019-07-21 16:36:26 +0200
committerMartin Franc2019-07-21 16:46:20 +0200
commit6247196c93e9a39b3188240ed6ba3c0d6dceefa3 (patch)
tree0bce9ecb20c1182bdb7026d404af16609586eecd
downloadaur-6247196c93e9a39b3188240ed6ba3c0d6dceefa3.tar.gz
wob 0.1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa4fe6dbaf1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wob
+ pkgdesc = A lightweight overlay volume/backlight/progress/anything bar for Wayland
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/francma/wob
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = git
+ makedepends = wayland-protocols
+ provides = wob
+ conflicts = wob
+ source = git+https://github.com/francma/wob#tag=0.1
+ sha512sums = SKIP
+
+pkgname = wob
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b9594b10423
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Martin Franc <me@martinfranc.eu>
+
+pkgname=wob
+pkgver=0.1
+pkgrel=1
+pkgdesc='A lightweight overlay volume/backlight/progress/anything bar for Wayland'
+arch=('i686' 'x86_64')
+url='https://github.com/francma/wob'
+license=('GPL3')
+makedepends=('meson' 'git' 'wayland-protocols')
+provides=('wob')
+conflicts=('wob')
+source=("git+${url}#tag=${pkgver}")
+sha512sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}
+ git submodule update --init --recursive
+ mkdir -p build-${pkgname}-${pkgver}
+ arch-meson build-${pkgname}-${pkgver} --buildtype release
+}
+
+build() {
+ cd ${pkgname}
+ ninja -C build-${pkgname}-${pkgver}
+}
+
+package() {
+ cd ${pkgname}
+ DESTDIR="$pkgdir" ninja -C build-${pkgname}-${pkgver} install
+}