summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2020-05-15 19:14:59 +0200
committerEric Engestrom2020-05-15 19:14:59 +0200
commitfcf35f4595a57ec39803c9eab32b312b0e76e766 (patch)
tree6d0ffa27a1c54c2bccee94411e59d1ac7dbc2bbf
downloadaur-fcf35f4595a57ec39803c9eab32b312b0e76e766.tar.gz
initial commit - 0.8+12.gd16c141393
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b4aaf006927
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wob-git
+ pkgdesc = A lightweight overlay volume/backlight/progress/anything bar for Wayland
+ pkgver = 0.8+12.gd16c141393
+ pkgrel = 1
+ url = https://github.com/francma/wob
+ arch = i686
+ arch = x86_64
+ license = ISC
+ makedepends = meson
+ makedepends = wayland-protocols
+ makedepends = scdoc
+ depends = wayland
+ provides = wob=0.8
+ conflicts = wob
+ source = https://github.com/francma/wob
+ sha512sums = SKIP
+
+pkgname = wob-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b486592b77df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+# Maintainer: Martin Franc <me@martinfranc.eu>
+
+pkgname=wob-git
+pkgver=0.8+12.gd16c141393
+pkgrel=1
+pkgdesc='A lightweight overlay volume/backlight/progress/anything bar for Wayland'
+arch=('i686' 'x86_64')
+url='https://github.com/francma/wob'
+license=('ISC')
+source=("git+$url")
+sha512sums=('SKIP')
+depends=('wayland')
+makedepends=('meson' 'wayland-protocols' 'scdoc')
+conflicts=('wob')
+provides=("wob=${pkgver%%+*}")
+
+pkgver() {
+ git -C wob describe --abbrev=10 | sed 's/-/+/; s/-/./'
+}
+
+build() {
+ arch-meson build wob \
+ -D b_ndebug=true
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm644 wob/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}