summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2021-01-09 01:12:50 +0100
committerFrederik Schwan2021-01-09 01:13:32 +0100
commit3b067d9abe4220146cc52afb27ec087b13306a54 (patch)
tree882acb505aef2a231f07bebc48d5508134d1ed14
parent5ff169cf045191a07221203731ab3c9ce13a3b78 (diff)
downloadaur-3b067d9abe4220146cc52afb27ec087b13306a54.tar.gz
import from [community]
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 22 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 015c338259a5..4e2f87a998ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = woeusb
pkgdesc = A Linux program to create Windows USB stick installer from a Windows DVD or an image
pkgver = 3.3.1
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/slacka/WoeUSB
arch = x86_64
license = GPL3
- makedepends = git
- depends = wxgtk2
- depends = grub
depends = dosfstools
+ depends = grub
+ depends = ntfs-3g
depends = parted
depends = wget
- depends = ntfs-3g
- optdepends = gksu
- conflicts = woeusb-git
- source = WoeUSB-3.3.1::git+https://github.com/slacka/WoeUSB.git#tag=v3.3.1
- sha256sums = SKIP
+ depends = wxgtk2
+ source = https://github.com/slacka/WoeUSB/archive/v3.3.1/woeusb-3.3.1.tar.gz
+ b2sums = 1423ecca39018c674b0eea36de732f54cfcdd14b8cc465e6d3c0639192cbd8355436b7a39ba453b19fa6f1c5b1f6938ef12f49710bc2a4af0f2eaed967e03ce7
pkgname = woeusb
diff --git a/PKGBUILD b/PKGBUILD
index 6eaa7097ec11..5d633897c171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,32 @@
-# Maintainer: Giovanni Harting <539@idlegandalf.com>
+# Maintainer: Frederik Schwan <freswa at archlinux dot org>
+# Contributor: Giovanni Harting <539@idlegandalf.com>
# Contributor: aimileus <me at aimileus dot nl>
# Contributor: Salvador PardiƱas <darkfm@vera.com.uy>
pkgname=woeusb
pkgver=3.3.1
-pkgrel=1
-pkgdesc="A Linux program to create Windows USB stick installer from a Windows DVD or an image"
+pkgrel=3
+pkgdesc='A Linux program to create Windows USB stick installer from a Windows DVD or an image'
arch=('x86_64')
-url="https://github.com/slacka/WoeUSB"
+url='https://github.com/slacka/WoeUSB'
license=('GPL3')
-depends=('wxgtk2' 'grub' 'dosfstools' 'parted' 'wget' 'ntfs-3g')
-makedepends=('git')
-optdepends=('gksu')
-conflicts=('woeusb-git')
-source=("WoeUSB-${pkgver}::git+https://github.com/slacka/WoeUSB.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+depends=('dosfstools' 'grub' 'ntfs-3g' 'parted' 'wget' 'wxgtk2')
+source=("https://github.com/slacka/WoeUSB/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+b2sums=('1423ecca39018c674b0eea36de732f54cfcdd14b8cc465e6d3c0639192cbd8355436b7a39ba453b19fa6f1c5b1f6938ef12f49710bc2a4af0f2eaed967e03ce7')
prepare() {
- cd "WoeUSB-$pkgver"
-
- grep 'filter=version' .gitattributes | cut -d' ' -f1 | while read file; do
- sed -i "s/@@WOEUSB_VERSION@@/${pkgver}/" $file
- done
-
- autoreconf --install
- ./configure --prefix=/usr
+ cd WoeUSB-${pkgver}
+ find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${pkgver}/" || die
+ autoreconf --install
}
build() {
- cd "WoeUSB-$pkgver"
- make
+ cd WoeUSB-${pkgver}
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "WoeUSB-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd WoeUSB-${pkgver}
+ make DESTDIR="${pkgdir}" install
}
-