summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Peschany2021-01-22 10:31:32 +0300
committerAlexey Peschany2021-01-22 10:31:32 +0300
commit5a51c130066c13aa69796658d87692c795c2f438 (patch)
tree33e41e38df8b44d6fc665bd1c7908b3944ae24c0
parente4fcd1e566900463d7fd39bcf373cfbc63264c43 (diff)
downloadaur-5a51c130066c13aa69796658d87692c795c2f438.tar.gz
Update to newest version 5.0.4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4301dd4fca70..8c1f03065cea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = woeusb
pkgdesc = A Linux program to create Windows USB stick installer from a Windows DVD or an image
- pkgver = 3.3.1
- pkgrel = 6
- url = https://github.com/slacka/WoeUSB
- arch = x86_64
+ pkgver = 5.0.4
+ pkgrel = 1
+ url = https://github.com/WoeUSB/WoeUSB
+ arch = any
license = GPL3
depends = dosfstools
depends = grub
depends = ntfs-3g
depends = parted
depends = wget
- depends = wxgtk2
- source = https://github.com/slacka/WoeUSB/archive/v3.3.1/woeusb-3.3.1.tar.gz
- b2sums = 1423ecca39018c674b0eea36de732f54cfcdd14b8cc465e6d3c0639192cbd8355436b7a39ba453b19fa6f1c5b1f6938ef12f49710bc2a4af0f2eaed967e03ce7
+ source = https://github.com/WoeUSB/WoeUSB/releases/download/v5.0.4/woeusb-5.0.4.bash
+ md5sums = 58f687c3c5e1922daf9c69517b7eac23
pkgname = woeusb
diff --git a/PKGBUILD b/PKGBUILD
index d17384595dd8..299b10de7179 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,21 @@
# Contributor: Salvador PardiƱas <darkfm@vera.com.uy>
pkgname=woeusb
-pkgver=3.3.1
-pkgrel=6
+pkgver=5.0.4
+pkgrel=1
pkgdesc='A Linux program to create Windows USB stick installer from a Windows DVD or an image'
-arch=('x86_64')
-url='https://github.com/slacka/WoeUSB'
+arch=('any')
+url='https://github.com/WoeUSB/WoeUSB'
license=('GPL3')
-depends=('dosfstools' 'grub' 'ntfs-3g' 'parted' 'wget' 'wxgtk2')
-source=("https://github.com/slacka/WoeUSB/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-b2sums=('1423ecca39018c674b0eea36de732f54cfcdd14b8cc465e6d3c0639192cbd8355436b7a39ba453b19fa6f1c5b1f6938ef12f49710bc2a4af0f2eaed967e03ce7')
+depends=('dosfstools' 'grub' 'ntfs-3g' 'parted' 'wget')
+source=("https://github.com/WoeUSB/WoeUSB/releases/download/v${pkgver}/woeusb-${pkgver}.bash")
+md5sums=(58f687c3c5e1922daf9c69517b7eac23)
prepare() {
- cd WoeUSB-${pkgver}
- find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${pkgver}/" || die
- autoreconf --install
-}
-
-build() {
- cd WoeUSB-${pkgver}
- ./configure --prefix=/usr
- make
+ chmod +x woeusb-$pkgver.bash
+ mv woeusb-$pkgver.bash woeusb
}
package() {
- cd WoeUSB-${pkgver}
- make DESTDIR="${pkgdir}" install
+ install -D -t "$pkgdir/usr/bin" "$srcdir/woeusb"
}