summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2020-02-21 10:39:20 +0100
committerGiovanni Harting2020-02-21 10:44:30 +0100
commit5ff169cf045191a07221203731ab3c9ce13a3b78 (patch)
tree3b4214c8b3d74d8a686e882e1fcf4d2c2a8c3ff1
parentd0e3991bf19a0ce3d9f540c27acccea751678513 (diff)
downloadaur-5ff169cf045191a07221203731ab3c9ce13a3b78.tar.gz
upgpkg: woeusb 3.3.1-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
-rw-r--r--disable_writeback_workaround.patch69
3 files changed, 20 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 080e91761730..015c338259a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = woeusb
pkgdesc = A Linux program to create Windows USB stick installer from a Windows DVD or an image
- pkgver = 3.3.0
- pkgrel = 2
+ pkgver = 3.3.1
+ pkgrel = 1
url = https://github.com/slacka/WoeUSB
arch = x86_64
license = GPL3
+ makedepends = git
depends = wxgtk2
depends = grub
depends = dosfstools
@@ -13,10 +14,8 @@ pkgbase = woeusb
depends = ntfs-3g
optdepends = gksu
conflicts = woeusb-git
- source = woeusb-3.3.0.tar.gz::https://github.com/slacka/WoeUSB/archive/v3.3.0.tar.gz
- source = disable_writeback_workaround.patch
- sha256sums = dc0e1a233143a33182339915d043a419c089b8bfb0d3813b17acbff2bdb285bb
- sha256sums = f051d9dbf1015596327b91abeea5c9f2404904e40e168f798fb4447e3fa9acb5
+ source = WoeUSB-3.3.1::git+https://github.com/slacka/WoeUSB.git#tag=v3.3.1
+ sha256sums = SKIP
pkgname = woeusb
diff --git a/PKGBUILD b/PKGBUILD
index 51f2a86588ba..6eaa7097ec11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,37 @@
# Contributor: Salvador Pardiñas <darkfm@vera.com.uy>
pkgname=woeusb
-pkgver=3.3.0
-pkgrel=2
+pkgver=3.3.1
+pkgrel=1
pkgdesc="A Linux program to create Windows USB stick installer from a Windows DVD or an image"
arch=('x86_64')
url="https://github.com/slacka/WoeUSB"
license=('GPL3')
depends=('wxgtk2' 'grub' 'dosfstools' 'parted' 'wget' 'ntfs-3g')
+makedepends=('git')
optdepends=('gksu')
conflicts=('woeusb-git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/slacka/WoeUSB/archive/v$pkgver.tar.gz"
- "disable_writeback_workaround.patch")
-sha256sums=('dc0e1a233143a33182339915d043a419c089b8bfb0d3813b17acbff2bdb285bb'
- 'f051d9dbf1015596327b91abeea5c9f2404904e40e168f798fb4447e3fa9acb5')
+source=("WoeUSB-${pkgver}::git+https://github.com/slacka/WoeUSB.git#tag=v${pkgver}")
+sha256sums=('SKIP')
prepare() {
- cd "WoeUSB-$pkgver"
+ cd "WoeUSB-$pkgver"
- # Disable changing kernel cache behaviour, since it fails on newer versions
- # See https://github.com/slacka/WoeUSB/issues/267
- patch -Np1 -i "${srcdir}/disable_writeback_workaround.patch"
+ grep 'filter=version' .gitattributes | cut -d' ' -f1 | while read file; do
+ sed -i "s/@@WOEUSB_VERSION@@/${pkgver}/" $file
+ done
- autoreconf --install
- ./configure --prefix=/usr
+ autoreconf --install
+ ./configure --prefix=/usr
}
build() {
- cd "WoeUSB-$pkgver"
- make
+ cd "WoeUSB-$pkgver"
+ make
}
package() {
- cd "WoeUSB-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "WoeUSB-$pkgver"
+ make DESTDIR="$pkgdir/" install
}
diff --git a/disable_writeback_workaround.patch b/disable_writeback_workaround.patch
deleted file mode 100644
index 57e51da914d4..000000000000
--- a/disable_writeback_workaround.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-diff -rupN WoeUSB-3.3.0/src/woeusb WoeUSB-3.3.0-fix/src/woeusb
---- WoeUSB-3.3.0/src/woeusb 2019-03-26 03:34:51.000000000 +0100
-+++ WoeUSB-3.3.0-fix/src/woeusb 2019-08-03 09:10:10.553378730 +0200
-@@ -308,9 +308,6 @@ init(){
-
- current_state=copying-filesystem
-
-- workaround_linux_make_writeback_buffering_not_suck \
-- apply
--
- copy_filesystem_files \
- "${source_fs_mountpoint}" \
- "${target_fs_mountpoint}" \
-@@ -1650,41 +1647,6 @@ workaround_support_windows_7_uefi_boot()
- > "${efi_boot_directory}/bootx64.efi"
- }; declare -fr workaround_support_windows_7_uefi_boot
-
--## Currently WoeUSB indirectly causes severely unresponsive system on 64-bit architecture with large primary memory during file copy process due to a flaw of the writeback buffer size handling in Linux kernel, workaround it before it is fixed
--## Refer:
--## - System lagging while copying data · Issue #113 · slacka/WoeUSB <https://github.com/slacka/WoeUSB/issues/113>
--## - The pernicious USB-stick stall problem [LWN.net] <https://lwn.net/Articles/572911/>
--workaround_linux_make_writeback_buffering_not_suck(){
-- util_check_function_parameters_quantity 1 "${#}"
-- local -r mode="${1}"
--
-- local -ir VM_DIRTY_BACKGROUND_BYTES=$((16*1024*1024)) # 16MiB
-- local -ir VM_DIRTY_BYTES=$((48*1024*1024)) # 48MiB
--
-- case "${mode}" in
-- apply)
-- echo_with_color \
-- yellow \
-- 'Applying workaround to prevent 64-bit systems with big primary memory from being unresponsive during copying files.'
-- echo "${VM_DIRTY_BACKGROUND_BYTES}" > /proc/sys/vm/dirty_background_bytes
-- echo "${VM_DIRTY_BYTES}" > /proc/sys/vm/dirty_bytes
-- ;;
-- reset)
-- echo_with_color \
-- yellow \
-- 'Resetting workaround to prevent 64-bit systems with big primary memory from being unresponsive during copying files.'
-- echo 0 > /proc/sys/vm/dirty_background_bytes
-- echo 0 > /proc/sys/vm/dirty_bytes
-- ;;
-- *)
-- printf_with_color \
-- red \
-- 'Fatal: %s: Unexpected *mode* encountered, please report bug.\n' \
-- "${FUNCNAME[0]}"
-- ;;
-- esac
--}; declare -fr workaround_linux_make_writeback_buffering_not_suck
--
- install_legacy_pc_bootloader_grub(){
- util_check_function_parameters_quantity 3 "${#}"
- local -r target_fs_mountpoint="${1}"; shift 1
-@@ -1836,13 +1798,6 @@ trap_exit(){
- off \
- "${global_only_for_gui}"
-
-- case "${current_state}" in
-- copying-filesystem|finished)
-- workaround_linux_make_writeback_buffering_not_suck \
-- reset
-- ;;
-- esac
--
- if util_is_parameter_set_and_not_empty \
- source_fs_mountpoint; then
- if ! cleanup_mountpoint \