summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-09-19 22:18:29 +0200
committerFabioLolix2018-09-19 22:18:29 +0200
commit341cc75b6b9edde7b707570a963383ef4827f662 (patch)
treef9ca61146b0b52488b0c156412ef4389e05fe348
parentd3ac3639934070a4e19d175ac82869d4d53257fe (diff)
downloadaur-341cc75b6b9edde7b707570a963383ef4827f662.tar.gz
Update build instruction and more
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 37 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df4a49539551..95934de1e263 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
pkgbase = woff2-git
- pkgdesc = Font compression reference code
- pkgver = r99.2855ee7
+ pkgdesc = Web Open Font Format 2 reference implementation
+ pkgver = 1.0.2.r4.ga0d0ed7
pkgrel = 1
url = https://github.com/google/woff2
- arch = i686
arch = x86_64
- license = Apache
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = custom:MIT
makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ depends = brotli
provides = woff2
conflicts = woff2
- source = woff2::git+https://github.com/google/woff2.git
+ source = woff2-git::git+https://github.com/google/woff2.git
md5sums = SKIP
pkgname = woff2-git
diff --git a/PKGBUILD b/PKGBUILD
index 25227e961a34..8ee3a082a63c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,38 @@
-# Maintainer: Auguste Pop <auguste [at] gmail [dot] com>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Contributor: Auguste Pop <auguste [at] gmail [dot] com>
pkgname=woff2-git
-pkgver=r99.2855ee7
+pkgver=1.0.2.r4.ga0d0ed7
pkgrel=1
-pkgdesc="Font compression reference code"
-arch=('i686' 'x86_64')
+pkgdesc="Web Open Font Format 2 reference implementation"
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://github.com/google/woff2"
-license=('Apache')
-makedepends=('git')
+license=(custom:MIT)
+depends=(brotli)
+makedepends=(git cmake ninja)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+https://github.com/google/woff2.git")
+source=("${pkgname}::git+https://github.com/google/woff2.git")
md5sums=('SKIP')
-pkgver()
-{
- cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build()
-{
- cd "$srcdir/${pkgname%-git}"
- git submodule init
- git submodule update
- make clean all
+prepare() {
+ cd "$pkgname"
+ sed -i 's/NOT BUILD_SHARED_LIBS/TRUE/' CMakeLists.txt
}
-package()
-{
- cd "$srcdir/${pkgname%-git}"
- for bin in woff2_compress woff2_decompress
- do
- install -m 755 -D "$bin" "${pkgdir}/usr/bin/$bin"
- done
+build() {
+ cd "$pkgname"
+ cmake -G Ninja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib .
+ ninja
+}
+
+package() {
+ cd "$pkgname"
+ DESTDIR="$pkgdir" ninja install
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE
}