summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Khanlar2016-01-24 08:30:30 -0500
committerJason Khanlar2016-01-24 08:30:30 -0500
commit09eb5a656b175399770575ec8c327ca7369e9713 (patch)
tree660d1b6fc71a123adebdbafaa8259fb7e3f5d9cb
downloadaur-09eb5a656b175399770575ec8c327ca7369e9713.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8327830b587f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Jan 24 13:30:00 UTC 2016
+pkgbase = wofftools
+ pkgdesc = A library for working with WOFF files.
+ pkgver = 0.1beta
+ pkgrel = 1
+ url = https://github.com/typesupply/woffTools
+ arch = any
+ license = MIT
+ depends = python2-fonttools
+ depends = python2-numpy
+ source = https://github.com/typesupply/woffTools/archive/master.zip
+ md5sums = 3c9358f147eff195449736c045a11d8b
+
+pkgname = wofftools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35a1de6de579
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jason Khanlar <jason.khanlar@gmail.com>
+pkgname=wofftools
+pkgver=0.1beta
+pkgrel=1
+pkgdesc="A library for working with WOFF files."
+arch=('any')
+url="https://github.com/typesupply/woffTools"
+license=('MIT')
+depends=('python2-fonttools' 'python2-numpy')
+source=(
+ "https://github.com/typesupply/woffTools/archive/master.zip"
+)
+md5sums=('3c9358f147eff195449736c045a11d8b')
+prepare() {
+ sed -i 's|^#!/usr/bin/env python|#!/usr/bin/env python2|' woffTools-master/setup.py
+}
+build() {
+ cd "woffTools-master"
+ chmod u+x setup.py
+ ./setup.py build
+}
+package() {
+ cd "woffTools-master"
+ install -Dm755 "woff-all" "$pkgdir/usr/bin/woff-all"
+ install -Dm755 "woff-css" "$pkgdir/usr/bin/woff-css"
+ install -Dm755 "woff-info" "$pkgdir/usr/bin/woff-info"
+ install -Dm755 "woff-proof" "$pkgdir/usr/bin/woff-proof"
+ install -Dm755 "woff-validate" "$pkgdir/usr/bin/woff-validate"
+}