summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeioth2022-12-13 23:22:24 +0100
committerZeioth2022-12-13 23:22:24 +0100
commit2c65011f40bc2f6543ccc5a5157f5ce4b5b49a6b (patch)
treed42129069106242b6dacb848e56a0639676322df
parent0222b3af8049569f570050d8659b29da61b43baf (diff)
downloadaur-2c65011f40bc2f6543ccc5a5157f5ce4b5b49a6b.tar.gz
Files accidentally pushed to AUR have been removed.
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
-rw-r--r--README.md20
-rwxr-xr-xpush-version-aur.sh14
-rwxr-xr-xwofi-calc.sh34
6 files changed, 6 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e28a9a6ec92..d9fa0f20954b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,9 +10,8 @@ pkgbase = wofi-calc-git
depends = wofi
depends = libqalculate
provides = wofi-calc-git
- conflicts = wofi-calc-git
conflicts = wofi-calc
- source = https://raw.githubusercontent.com/Zeioth/wofi-calc/master/wofi-calc.sh
- sha256sums = 0bc4930e7df685389309198ce214ebf3b88aee71ca0198f586ff0afe6bea716b
+ source = git+https://github.com/Zeioth/wofi-calc.git
+ sha256sums = SKIP
pkgname = wofi-calc-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 6e92f57d4647..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-tags
diff --git a/PKGBUILD b/PKGBUILD
index 32f8790969b0..e7b669c51d36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,15 +12,15 @@ makedepends=(wofi libqalculate)
checkdepends=()
optdepends=()
provides=(wofi-calc-git)
-conflicts=(wofi-calc-git wofi-calc)
+conflicts=(wofi-calc)
replaces=()
backup=()
options=()
install=
changelog=
-source=("https://raw.githubusercontent.com/Zeioth/wofi-calc/master/wofi-calc.sh")
+source=("git+$url")
noextract=()
-sha256sums=('0bc4930e7df685389309198ce214ebf3b88aee71ca0198f586ff0afe6bea716b')
+sha256sums=('SKIP')
validpgpkeys=()
pkgver() {
@@ -31,5 +31,5 @@ pkgver() {
package() {
# Note: 'install' is a chmod+cp one-liner command by GNU
mkdir -p "$pkgdir"/usr/bin
- install -m 555 "${srcdir}"/wofi-calc.sh "$pkgdir"/usr/bin/wofi-calc
+ install -m 555 "${srcdir}"/wofi-calc/wofi-calc.sh "$pkgdir"/usr/bin/wofi-calc
}
diff --git a/README.md b/README.md
deleted file mode 100644
index e0e23130a540..000000000000
--- a/README.md
+++ /dev/null
@@ -1,20 +0,0 @@
-# wofi-calc
-A simple calculator for wofi, inspired in rofi-calc.
-
-## Install from AUR
-
- yay -S wofi-calc
-
-## Install from github
-
- makepkg -sri
-
-## To use it run
-
- wofi-calc
-
-## Changelog → Changes of 'wofi-calc-git' compared with 'wofi-calc'
-
- * wofi-calc now installs in /usr/bin instead of ~/.local/bin to make it available to all users.
- * Checksums added for extra security.
- * Automated build now generate checksums automatically.
diff --git a/push-version-aur.sh b/push-version-aur.sh
deleted file mode 100755
index ea0e79043805..000000000000
--- a/push-version-aur.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-# Generate the checksums automatically
-sed -i "s/^sha256sums=.*/$(makepkg -g -f -p PKGBUILD)/" ./PKGBUILD
-
-# Generate pagkage metadata
-makepkg --printsrcinfo > .SRCINFO
-
-# Push it to AUR
-git add PKGBUILD .SRCINFO
-git commit -m "New version"
-git push ssh://aur@aur.archlinux.org/wofi-calc-git.git master
-
-# Bye
-echo -e "\n-------------------------------------------------------------------"
-echo -e "NEW VERSION GENERATED\n"
diff --git a/wofi-calc.sh b/wofi-calc.sh
deleted file mode 100755
index 72fea609acaf..000000000000
--- a/wofi-calc.sh
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/usr/bin/env bash
-
-RESULT_FILE="$HOME/.config/qalculate/qalc.result.history"
-if [ ! -f "$RESULT_FILE" ]; then
- touch $RESULT_FILE
-fi
-
-LAST_WOFI=""
-QALC_RET=""
-while :
-do
- qalc_hist=`tac $RESULT_FILE | head -1000`
- WOFI_RET=`wofi --sort-order=default --cache-file=/dev/null -d -p calc <<< "$qalc_hist"`
-
- rtrn=$?
-
- if test "$rtrn" = "0"; then
- if [[ "$WOFI_RET" =~ .*=.* ]]; then
- RESULT=`echo "$WOFI_RET" | awk {'print $NF'}`
- wl-copy "$RESULT"
- exit 0
- else
- QALC_RET=`qalc "$WOFI_RET"`
- LAST_WOFI=$WOFI_RET
- echo $QALC_RET >> $RESULT_FILE
- fi
- else
- if [ ! -z "$LAST_WOFI" ]; then
- RESULT=`qalc -t "$LAST_WOFI"`
- wl-copy "$RESULT"
- fi
- exit 0
- fi
-done