summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeioth2021-12-30 23:24:47 +0100
committerZeioth2021-12-30 23:24:47 +0100
commitb1d537d413de2becafc67b432436a90d5e4da1d0 (patch)
treef8a29f65a0c2985d4c15fb5b06d9060b3582e222
downloadaur-b1d537d413de2becafc67b432436a90d5e4da1d0.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dae96a46f7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wofi-calc-git
+ pkgdesc = A simple calculator for wofi, inspired in rofi-calc.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Zeioth/wofi-calc.git
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = wofi
+ makedepends = libqalculate
+ depends = wofi
+ depends = libqalculate
+ provides = wofi-calc-git
+ conflicts = wofi-calc
+ source = git+https://github.com/Zeioth/wofi-calc.git
+ md5sums = SKIP
+
+pkgname = wofi-calc-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bc98c9a8e25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Adrian Lopez <zeioth@hotmail.com>
+pkgname=wofi-calc-git
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="A simple calculator for wofi, inspired in rofi-calc."
+arch=(x86_64 i686)
+url="https://github.com/Zeioth/wofi-calc.git"
+license=('MIT')
+groups=()
+depends=(wofi libqalculate)
+makedepends=(wofi libqalculate)
+checkdepends=()
+optdepends=()
+provides=(wofi-calc-git)
+conflicts=(wofi-calc)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cp "${srcdir}"/wofi-calc/wofi-calc.sh ~/.local/bin/wofi-calc
+ chmod u+x ~/.local/bin/wofi-calc
+}