summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Schmidt2023-08-18 23:08:23 +0200
committerAndreas Schmidt2023-08-18 23:08:23 +0200
commit31681d228e5758f0d63eb1abe9ae0c6e5e3a5773 (patch)
treea99e78904232d58b9855ba78879c0b354e5afd40
parentcc1e1b323b2681eec121166aa84396eb88035d61 (diff)
downloadaur-31681d228e5758f0d63eb1abe9ae0c6e5e3a5773.tar.gz
switch to new repository and add installation of man pages
Signed-off-by: Andreas Schmidt <mail@schmidt-andreas.de>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25ac703ad974..6a6f30f84d1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = wofi-pass
pkgdesc = A Wayland-native interface for conveniently using pass
- pkgver = VERSION
- pkgrel = 3
- url = https://github.com/TinfoilSubmarine/wofi-pass
+ pkgver = v23.1.0
+ pkgrel = 1
+ url = https://github.com/schmidtandreas/wofi-pass
arch = any
license = GPL
- makedepends = jq
depends = coreutils
depends = findutils
depends = grep
@@ -17,7 +16,10 @@ pkgbase = wofi-pass
depends = wofi
optdepends = wtype: type support
optdepends = pass-otp: OTP support
- source = https://raw.githubusercontent.com/TinfoilSubmarine/wofi-pass/master/wofi-pass
- sha512sums = a7a18053772e5c675380562a7d77fb56cd20481aa817b86e762a8fef292df24f7c4169f34f6a53b6997a39db460f56be9120b3eeedf58ef4edd7d3957abc00ee
+ noextract = wofi-pass.1.gz
+ source = https://github.com/schmidtandreas/wofi-pass/releases/download/v23.1.0/wofi-pass
+ source = https://github.com/schmidtandreas/wofi-pass/releases/download/v23.1.0/wofi-pass.1.gz
+ sha256sums = fa9b83de483e6dd281285420117105175379a29245f26a1166848e8cced0c1d4
+ sha256sums = cb355afb6180dd6d92ed46a804cbffd2ca2acd72762da0eb7bb89b7ba58486b4
pkgname = wofi-pass
diff --git a/PKGBUILD b/PKGBUILD
index e953f2a0d9f4..7337d8fb475d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: noobping <hello@noobping.dev>
+# Maintainer: schmidtandreas <mail@schmidt-andreas.de>
pkgname=wofi-pass
-pkgver=VERSION
-pkgrel=3
+pkgver="$(curl --silent https://api.github.com/repos/schmidtandreas/wofi-pass/releases/latest | grep "tag_name" | cut -d ":" -f 2 | sed "s|.*\"\(.*\)\".*|\1|")"
+pkgrel=1
pkgdesc="A Wayland-native interface for conveniently using pass"
arch=('any')
-url='https://github.com/TinfoilSubmarine/wofi-pass'
+url='https://github.com/schmidtandreas/wofi-pass'
license=('GPL')
depends=('coreutils' 'findutils' 'grep' 'man-pages' 'pass' 'tcl' 'util-linux' 'wl-clipboard' 'wofi')
-optdepends=(
- 'wtype: type support'
- 'pass-otp: OTP support')
-makedepends=('jq')
-source=(https://raw.githubusercontent.com/TinfoilSubmarine/wofi-pass/master/wofi-pass)
-sha512sums=('a7a18053772e5c675380562a7d77fb56cd20481aa817b86e762a8fef292df24f7c4169f34f6a53b6997a39db460f56be9120b3eeedf58ef4edd7d3957abc00ee')
-
-pkgver() {
- printf "r%s" "$(curl --silent https://api.github.com/repos/TinfoilSubmarine/wofi-pass/commits | jq -r length)"
-}
+optdepends=('wtype: type support'
+ 'pass-otp: OTP support')
+source=("https://github.com/schmidtandreas/wofi-pass/releases/download/${pkgver}/wofi-pass"
+ "https://github.com/schmidtandreas/wofi-pass/releases/download/${pkgver}/wofi-pass.1.gz")
+sha256sums=('fa9b83de483e6dd281285420117105175379a29245f26a1166848e8cced0c1d4'
+ 'cb355afb6180dd6d92ed46a804cbffd2ca2acd72762da0eb7bb89b7ba58486b4')
+noextract=("wofi-pass.1.gz")
package() {
mkdir -p "$pkgdir"/usr/bin
- install -m755 wofi-pass "$pkgdir"/usr/bin/wofi-pass
+ mkdir -p "$pkgdir"/usr/share/man/man1
+ install -m755 "wofi-pass" "$pkgdir"/usr/bin/wofi-pass
+ install -m755 "wofi-pass.1.gz" "$pkgdir"/usr/share/man/man1/wofi-pass.1.gz
}