summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhello@noobping.dev2022-04-06 21:21:15 +0200
committerhello@noobping.dev2022-04-06 21:21:15 +0200
commit436a7ec856800a5cdfd73686f82ddedcce5b4c33 (patch)
tree5094577bcff6ee6b93929b25ebc878a27b8f6068
downloadaur-436a7ec856800a5cdfd73686f82ddedcce5b4c33.tar.gz
wofi-pass
A Wayland-native interface for conveniently using pass
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD19
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6e22441dbc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wofi-pass
+ pkgdesc = A Wayland-native interface for conveniently using pass
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/TinfoilSubmarine/wofi-pass
+ arch = any
+ license = GPL
+ depends = coreutils
+ depends = findutils
+ depends = grep
+ depends = man-pages
+ depends = pass
+ depends = tcl
+ depends = util-linux
+ depends = wl-clipboard
+ depends = wofi
+ depends = wtype
+ optdepends = pass-otp: for OTP support
+ source = https://raw.githubusercontent.com/purplg/wofi-pass/master/wofi-pass
+ sha512sums = c47d7067dedc0038d75625ecd10a5b37560862cb4f6209b140951fb27dc2979245906dbbcd03e0fe9b35b1aafb3faf15d95b22a528df3a4143563aa302c3cc46
+
+pkgname = wofi-pass
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2b0c0734b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae181b987762
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: noobping <hello@noobping.dev>
+# Contributor: noobping <hello@noobping.dev>
+
+pkgname=wofi-pass
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A Wayland-native interface for conveniently using pass"
+arch=('any')
+url='https://github.com/TinfoilSubmarine/wofi-pass'
+license=('GPL')
+depends=('coreutils' 'findutils' 'grep' 'man-pages' 'pass' 'tcl' 'util-linux' 'wl-clipboard' 'wofi' 'wtype')
+optdepends=('pass-otp: for OTP support')
+source=(https://raw.githubusercontent.com/purplg/wofi-pass/master/wofi-pass)
+sha512sums=('c47d7067dedc0038d75625ecd10a5b37560862cb4f6209b140951fb27dc2979245906dbbcd03e0fe9b35b1aafb3faf15d95b22a528df3a4143563aa302c3cc46')
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ install -m755 wofi-pass "$pkgdir"/usr/bin/wofi-pass
+}