summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2023-09-11 22:37:39 +0200
committergit user2023-09-11 22:37:39 +0200
commit3f1b55cb1a89ff22a68c5782abc49b64088d1a3d (patch)
tree03fccd5dd8c0faed59413b17e9dbd48a8a949566
parent855bd21ed5163ac1034f282c602d2476a5b1de89 (diff)
downloadaur-3f1b55cb1a89ff22a68c5782abc49b64088d1a3d.tar.gz
Added a patch `remove-nm-dispatcher-woice-path-hardcoding.patch` that removes `woice` executable path hardcoding in NetworkManager dispatcher.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--remove-nm-dispatcher-woice-path-hardcoding.patch9
3 files changed, 20 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01e36dddb202..d95dadee705e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = woice-git
pkgdesc = Automatic login script for WIFIonICE public WiFi by Deutsche Bahn captive portals.
pkgver = 0.0.3.r9.20230326.3761b8f
- pkgrel = 1
+ pkgrel = 2
epoch = 0
url = https://github.com/keans/woice
arch = any
@@ -26,6 +26,8 @@ pkgbase = woice-git
conflicts = nm-wifionice-login
conflicts = nm-wifionice-login-git
source = woice::git+https://github.com/keans/woice.git
+ source = remove-nm-dispatcher-woice-path-hardcoding.patch
sha256sums = SKIP
+ sha256sums = a527136839843829ecbb2aff4158675db9862523fcebda56f5e9d5858c06e1fe
pkgname = woice-git
diff --git a/PKGBUILD b/PKGBUILD
index 2d196a3c8d02..cd71a3206d3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=woice
pkgname="${_pkgname}-git"
epoch=0
pkgver=0.0.3.r9.20230326.3761b8f
-pkgrel=1
+pkgrel=2
pkgdesc='Automatic login script for WIFIonICE public WiFi by Deutsche Bahn captive portals.'
url='https://github.com/keans/woice'
arch=(any)
@@ -39,14 +39,21 @@ conflicts=(
)
source=(
"${_pkgname}::git+${url}.git"
+ "remove-nm-dispatcher-woice-path-hardcoding.patch"
)
sha256sums=(
'SKIP'
+ 'a527136839843829ecbb2aff4158675db9862523fcebda56f5e9d5858c06e1fe'
)
prepare() {
cd "${srcdir}/${_pkgname}"
+ for _patch in "${srcdir}"/remove-nm-dispatcher-woice-path-hardcoding.patch; do
+ msg2 "Applyng patch `basename ${_patch}` ..."
+ patch -Np1 --follow-symlinks -i "${_patch}"
+ done
+
git log > git.log
}
diff --git a/remove-nm-dispatcher-woice-path-hardcoding.patch b/remove-nm-dispatcher-woice-path-hardcoding.patch
new file mode 100644
index 000000000000..3b62eda914d7
--- /dev/null
+++ b/remove-nm-dispatcher-woice-path-hardcoding.patch
@@ -0,0 +1,9 @@
+diff -rU0 woice.orig/examples/wifionice.sh woice/examples/wifionice.sh
+--- woice.orig/examples/wifionice.sh 2023-09-11 22:31:00.163417614 +0200
++++ woice/examples/wifionice.sh 2023-09-11 22:31:54.336754674 +0200
+@@ -2,0 +3,2 @@
++set -e
++
+@@ -13 +15 @@
+-WOICE="/usr/local/bin/woice"
++WOICE="`which woice`"