summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-04-11 22:42:41 +0800
committerzxp198210052023-04-11 22:42:41 +0800
commit1d510b1d39ba02c86f32eb4384c7492ff6a23536 (patch)
treea71f3888868e77086c732995336a56e340992e87
parent4f2f9f6ed9c17cd1ada8c4db642ea3cd032ace2d (diff)
downloadaur-1d510b1d39ba02c86f32eb4384c7492ff6a23536.tar.gz
update to 1.2.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cace4f74e55..8e3e2061845f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wolai-bin
pkgdesc = wolai是一种新形态的文档/笔记/信息系统,它与你过去使用的所有传统文档、在线文档都有很多不同,学会使用wolai就等于拥有了一个强大的个人与团队生产力工具。
- pkgver = 1.2.6
- pkgrel = 4
+ pkgver = 1.2.7
+ pkgrel = 1
url = https://www.wolai.com/
arch = x86_64
license = custom
@@ -30,9 +30,9 @@ pkgbase = wolai-bin
depends = dbus
depends = alsa-lib
provides = wolai
- source = wolai-1.2.6.deb::https://cdn.wostatic.cn/dist/installers/wolai_1.2.6_amd64.deb
+ source = wolai-1.2.7.deb::https://cdn.wostatic.cn/dist/installers/wolai_1.2.7_amd64.deb
source = LICENSE::https://www.wolai.com/pricing
- sha256sums = 9b5840ddaef1acad3e2aed8ec3bdf5dee39eed413f0b20baf769d84d68af7da3
- sha256sums = fd1194922db6f08a44cd9a0acc2e2b693da58d520ce6b105bc3827754ad8c76f
+ sha256sums = c6dadbc374f9d536a8cf039d748b0e5eb74a90e3b6630abb787d5c0442e78469
+ sha256sums = a18cf1777eb2af01b6ba1e4d72828f37e3447c502819144c14cccaecb184d0b6
pkgname = wolai-bin
diff --git a/PKGBUILD b/PKGBUILD
index 51bfaa56181e..8030a52569b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: zhullyb <zhullyb [at] outlook dot com>
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-_pkgname=wolai
-pkgname="${_pkgname}-bin"
-pkgver=1.2.6
-pkgrel=4
+pkgname="wolai-bin"
+pkgver=1.2.7
+pkgrel=1
pkgdesc="wolai是一种新形态的文档/笔记/信息系统,它与你过去使用的所有传统文档、在线文档都有很多不同,学会使用wolai就等于拥有了一个强大的个人与团队生产力工具。"
arch=("x86_64")
url="https://www.wolai.com/"
license=('custom')
-depends=(hicolor-icon-theme libcups nss cairo libxdamage libxfixes pango libxext gtk3 libxcomposite nspr \
- libdrm gcc-libs libxcb libx11 expat glibc libxrandr libxkbcommon mesa glib2 at-spi2-core dbus alsa-lib)
-provides=("${_pkgname}")
-source=("${_pkgname}-${pkgver}.deb::https://cdn.wostatic.cn/dist/installers/${_pkgname}_${pkgver}_amd64.deb"
+depends=('hicolor-icon-theme' 'libcups' 'nss' 'cairo' 'libxdamage' 'libxfixes' 'pango' 'libxext' 'gtk3' 'libxcomposite' 'nspr' \
+ 'libdrm' 'gcc-libs' 'libxcb' 'libx11' 'expat' 'glibc' 'libxrandr' 'libxkbcommon' 'mesa' 'glib2' 'at-spi2-core' 'dbus' 'alsa-lib')
+provides=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.deb::https://cdn.wostatic.cn/dist/installers/${pkgname%-bin}_${pkgver}_amd64.deb"
"LICENSE::https://www.wolai.com/pricing")
-sha256sums=('9b5840ddaef1acad3e2aed8ec3bdf5dee39eed413f0b20baf769d84d68af7da3'
- 'fd1194922db6f08a44cd9a0acc2e2b693da58d520ce6b105bc3827754ad8c76f')
+sha256sums=('c6dadbc374f9d536a8cf039d748b0e5eb74a90e3b6630abb787d5c0442e78469'
+ 'a18cf1777eb2af01b6ba1e4d72828f37e3447c502819144c14cccaecb184d0b6')
package() {
bsdtar -xf data.tar.xz -C "${pkgdir}"
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-} \ No newline at end of file
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}