summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-09 16:40:59 +0800
committerzxp198210052024-04-09 16:40:59 +0800
commitbb55948a180fbc564f7c78bb7087f5dc80e4be24 (patch)
treed11142978903009dc61a4a8ed17595ee822ff002
parent2b767fe966a656c56f27f36d1eafb49ba48cb1b8 (diff)
downloadaur-bb55948a180fbc564f7c78bb7087f5dc80e4be24.tar.gz
fix errors
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--wolai.sh7
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e6409d74325..b3c760c6ddb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wolai-bin
pkgdesc = wolai是一种新形态的文档/笔记/信息系统,它与你过去使用的所有传统文档、在线文档都有很多不同,学会使用wolai就等于拥有了一个强大的个人与团队生产力工具。
pkgver = 1.2.9
- pkgrel = 5
+ pkgrel = 6
url = https://www.wolai.com
arch = aarch64
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index deae6400361c..b4bdf5b76dfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wolai-bin
pkgver=1.2.9
_electronversion=22
-pkgrel=5
+pkgrel=6
pkgdesc="wolai是一种新形态的文档/笔记/信息系统,它与你过去使用的所有传统文档、在线文档都有很多不同,学会使用wolai就等于拥有了一个强大的个人与团队生产力工具。"
arch=(
"aarch64"
diff --git a/wolai.sh b/wolai.sh
index e6784b369c25..7ddcaab8d734 100644
--- a/wolai.sh
+++ b/wolai.sh
@@ -1,7 +1,8 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file