summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit9e4d8094ce3db7edc034f72decc8bdcdd86d5191 (patch)
tree036c9b39c0674f6ea33d8fcfa12e9fa130f914d9
downloadaur-9e4d8094ce3db7edc034f72decc8bdcdd86d5191.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD95
-rw-r--r--wolf.install24
-rw-r--r--wolf.launcher7
-rw-r--r--wolfded.launcher7
-rw-r--r--wolfmp.desktop10
-rw-r--r--wolfmp.launcher7
-rw-r--r--wolfsp.desktop10
-rw-r--r--wolfsp.launcher7
10 files changed, 201 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37b868c67871
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = wolf
+ pkgdesc = Return to Castle Wolfenstein is a single and multiplayer first person shooter. You need the retail game files to play.
+ pkgver = 1.41b
+ pkgrel = 3
+ url = http://zerowing.idsoftware.com/linux/wolf/
+ install = wolf.install
+ arch = i686
+ license = custom
+ depends = libgl
+ depends = libxext
+ source = wolfsp.desktop
+ source = wolfmp.desktop
+ source = wolf.launcher
+ source = wolfsp.launcher
+ source = wolfmp.launcher
+ source = wolfded.launcher
+ source = http://www.slashbunny.com/aur/wolf/libstdc++-libc6.2-2.so.3
+ source = ftp://ftp.internat.freebsd.org/pub/FreeBSD/distfiles/wolf-linux-1.41b.x86.run
+ md5sums = dbc81736f44e38496df2dfd6282364e6
+ md5sums = b04b3a8fdb0c288aa00adb2cdb859724
+ md5sums = ba4d698848b548b1b1cab4e121d0b1e3
+ md5sums = dc663542081c157567a743ba24e76735
+ md5sums = ba4d698848b548b1b1cab4e121d0b1e3
+ md5sums = 11bcba217cf10252cb980f70f32c6e19
+ md5sums = 84824b4081be220646a5804327c28546
+ md5sums = 2aa37968aff19d665ed6c001773b2de3
+
+pkgname = wolf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57fb34078ad1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,95 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=wolf
+pkgver=1.41b
+pkgrel=3
+pkgdesc="Return to Castle Wolfenstein is a single and multiplayer first person shooter. You need the retail game files to play."
+arch=('i686')
+url="http://zerowing.idsoftware.com/linux/wolf/"
+license=('custom')
+depends=('libgl' 'libxext')
+makedepends=()
+install='wolf.install'
+source=('wolfsp.desktop' 'wolfmp.desktop' \
+'wolf.launcher' 'wolfsp.launcher' 'wolfmp.launcher' 'wolfded.launcher' \
+'http://www.slashbunny.com/aur/wolf/libstdc++-libc6.2-2.so.3' \
+"ftp://ftp.internat.freebsd.org/pub/FreeBSD/distfiles/wolf-linux-${pkgver}.x86.run")
+md5sums=('dbc81736f44e38496df2dfd6282364e6'
+ 'b04b3a8fdb0c288aa00adb2cdb859724'
+ 'ba4d698848b548b1b1cab4e121d0b1e3'
+ 'dc663542081c157567a743ba24e76735'
+ 'ba4d698848b548b1b1cab4e121d0b1e3'
+ '11bcba217cf10252cb980f70f32c6e19'
+ '84824b4081be220646a5804327c28546'
+ '2aa37968aff19d665ed6c001773b2de3')
+
+build() {
+ # Create Destination Directories
+ install -d $pkgdir/opt/wolf/ $pkgdir/usr/bin/ $srcdir/wolf/
+
+ # Set Install Files to Executable
+ chmod +x $srcdir/wolf-linux-${pkgver}.x86.run
+
+ # Extract Linux Game Files
+ cd $srcdir/wolf/
+ $srcdir/wolf-linux-${pkgver}.x86.run --noexec --tar xf --group=root --owner=root
+
+ # Move Binaries to Main Directory
+ cp $srcdir/wolf/bin/Linux/x86/{wolf.x86,wolfded.x86,wolfsp.x86} $srcdir/wolf/
+
+ # Remove Unneeded Files and Directories
+ rm -r $srcdir/wolf/{bin,setup.data,setup.sh,CHANGES~}
+
+ # Fix Permissions (Owner, Directory, and File Permissions)
+ /bin/chown -R root:root $srcdir/wolf/
+ /bin/chmod 0755 $srcdir/wolf/Docs/PunkBuster
+ /bin/chmod 0644 $srcdir/wolf/{Docs/{PunkBuster/{admins/index.htm,players/index.htm},Update_readme.htm},RTCW-README-1.4.txt}
+
+ # Move Data to Package Directory
+ mv $srcdir/wolf/ $pkgdir/opt/
+
+ # Install Launcher Script (Single Player Client)
+ install -D -m 755 $srcdir/wolfsp.launcher \
+ $pkgdir/usr/bin/wolfsp
+
+ # Install Launcher Script (Multiplayer Client)
+ install -D -m 755 $srcdir/wolf.launcher \
+ $pkgdir/usr/bin/wolf
+
+ # Install Launcher Script (Multiplayer Client)
+ install -D -m 755 $srcdir/wolfmp.launcher \
+ $pkgdir/usr/bin/wolfmp
+
+ # Install Launcher Script (Multipler Server)
+ install -D -m 755 $srcdir/wolfded.launcher \
+ $pkgdir/usr/bin/wolfded
+
+ # Install old libstdc++ library needed for Wolf to run
+ install -D -m 755 $srcdir/libstdc++-libc6.2-2.so.3 \
+ $pkgdir/opt/wolf/libstdc++-libc6.2-2.so.3
+
+ # Install License (Return to Castle Wolfenstein)
+ install -D -m 644 $pkgdir/opt/wolf/Docs/License.txt \
+ $pkgdir/usr/share/licenses/$pkgname/License.txt
+
+ # Install License (PunkBuster)
+ install -D -m 644 $pkgdir/opt/wolf/pb/PB_EULA.txt \
+ $pkgdir/usr/share/licenses/$pkgname/PB_EULA.txt
+
+ # Install Desktop File (Single Player)
+ install -D -m 644 $srcdir/wolfsp.desktop \
+ $pkgdir/usr/share/applications/wolfsp.desktop
+
+ # Install Desktop File (Multi Player)
+ install -D -m 644 $srcdir/wolfmp.desktop \
+ $pkgdir/usr/share/applications/wolfmp.desktop
+
+ # Install Icon File (Single Player)
+ install -D -m 644 $pkgdir/opt/wolf/WolfSP.xpm \
+ $pkgdir/usr/share/pixmaps/WolfSP.xpm
+
+ # Install Icon File (Multi Player)
+ install -D -m 644 $pkgdir/opt/wolf/WolfMP.xpm \
+ $pkgdir/usr/share/pixmaps/WolfMP.xpm
+}
+
diff --git a/wolf.install b/wolf.install
new file mode 100644
index 000000000000..9dc18e2ef834
--- /dev/null
+++ b/wolf.install
@@ -0,0 +1,24 @@
+
+post_install() {
+ echo ">>> Copy the following files off a Windows installation or CD-ROM to the"
+ echo ">>> /opt/wolf/main/ directory in order to play:"
+ echo ">>>"
+ echo ">>> pak0.pk3"
+ echo ">>> sp_pak1.pk3"
+ echo ">>> mp_pak0.pk3"
+ echo ">>>"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*
+
diff --git a/wolf.launcher b/wolf.launcher
new file mode 100644
index 000000000000..33ada10aff5e
--- /dev/null
+++ b/wolf.launcher
@@ -0,0 +1,7 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# the binaries must run with correct working directory
+cd "/opt/wolf"
+export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:."
+exec ./wolf.x86 "$@"
+
diff --git a/wolfded.launcher b/wolfded.launcher
new file mode 100644
index 000000000000..3b7ab1985f7e
--- /dev/null
+++ b/wolfded.launcher
@@ -0,0 +1,7 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# the binaries must run with correct working directory
+cd "/opt/wolf"
+export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:."
+exec ./wolfded.x86 "$@"
+
diff --git a/wolfmp.desktop b/wolfmp.desktop
new file mode 100644
index 000000000000..7a8b4af80d7b
--- /dev/null
+++ b/wolfmp.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Return To Castle Wolfenstein MP
+Comment=Return To Castle Wolfenstein (Multi Player)
+Exec=/usr/bin/wolfmp
+Icon=/usr/share/pixmaps/WolfMP.xpm
+Terminal=false
+Categories=Game
+
diff --git a/wolfmp.launcher b/wolfmp.launcher
new file mode 100644
index 000000000000..33ada10aff5e
--- /dev/null
+++ b/wolfmp.launcher
@@ -0,0 +1,7 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# the binaries must run with correct working directory
+cd "/opt/wolf"
+export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:."
+exec ./wolf.x86 "$@"
+
diff --git a/wolfsp.desktop b/wolfsp.desktop
new file mode 100644
index 000000000000..d4f39a3877f2
--- /dev/null
+++ b/wolfsp.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Return To Castle Wolfenstein SP
+Comment=Return To Castle Wolfenstein (Single Player)
+Exec=/usr/bin/wolfsp
+Icon=/usr/share/pixmaps/WolfSP.xpm
+Terminal=false
+Categories=Game
+
diff --git a/wolfsp.launcher b/wolfsp.launcher
new file mode 100644
index 000000000000..d0e2b3ddb6e0
--- /dev/null
+++ b/wolfsp.launcher
@@ -0,0 +1,7 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# the binaries must run with correct working directory
+cd "/opt/wolf"
+export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:."
+exec ./wolfsp.x86 "$@"
+