summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-10-28 14:00:37 +0200
committerChristopher Arndt2023-10-28 14:35:37 +0200
commitbc28827204270809cc6a3f40b72cc4a59f5427a2 (patch)
treeea3e02004e2bb5f98a104239dd68ffe99eb27137
parentfa5bb2940e9c561666ca5678f99d8a3600ba8102 (diff)
downloadaur-bc28827204270809cc6a3f40b72cc4a59f5427a2.tar.gz
Rework PKGBUILD
-rw-r--r--.SRCINFO48
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD95
3 files changed, 124 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28adc7c06a1e..a1a420f92074 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,62 @@
pkgbase = wolf-shaper-git
- pkgdesc = Waveshaper plugin w/ graph editor
- pkgver = 0.1.8.r62.g6b1ac64
+ pkgdesc = A waveshaper plugin with graph editor (git version)
+ pkgver = 1.0.2.r22.gd34289f
pkgrel = 1
url = https://github.com/wolf-plugins/wolf-shaper
arch = i686
arch = x86_64
+ groups = pro-audio
+ groups = dssi-plugins
+ groups = clap-plugins
+ groups = lv2-plugins
+ groups = vst-plugins
+ groups = vst3-plugins
license = GPL
+ makedepends = alsa-lib
makedepends = dssi
- makedepends = lv2
+ makedepends = gcc-libs
+ makedepends = gendesk
+ makedepends = glibc
makedepends = jack
+ makedepends = liblo
+ makedepends = libglvnd
+ makedepends = libx11
+ makedepends = libxext
+ makedepends = lv2
+ depends = gcc-libs
+ depends = glibc
+ depends = libxext
depends = libglvnd
depends = libx11
optdepends = jack: for standalone application
+ optdepends = dssi-host: for loading the DSSI format plugin
+ optdepends = clap-host: for loading the CLAP format plugin
+ optdepends = lv2-host: for loading the LV2 format plugin
+ optdepends = vst-host: for loading the VST2 format plugin
+ optdepends = vst3-host: for loading the VST3 format plugin
provides = wolf-shaper
+ provides = wolf-shaper-clap
+ provides = wolf-shaper-dssi
+ provides = wolf-shaper-lv2
+ provides = wolf-shaper-standalone
+ provides = wolf-shaper-vst
+ provides = wolf-shaper-vst3
conflicts = wolf-shaper
+ conflicts = wolf-shaper-clap
+ conflicts = wolf-shaper-dssi
+ conflicts = wolf-shaper-lv2
+ conflicts = wolf-shaper-standalone
+ conflicts = wolf-shaper-vst
+ conflicts = wolf-shaper-vst3
source = wolf-shaper::git+https://github.com/wolf-plugins/wolf-shaper
md5sums = SKIP
pkgname = wolf-shaper-git
+ depends = gcc-libs
+ depends = glibc
+ depends = libxext
+ depends = libglvnd
+ depends = libx11
+ depends = libasound.so
+ depends = libGL.so
+ depends = liblo.so
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1ced0c305978
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pakg/
+src/
+wolf-shaper/
+wolf-shaper-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 4be97124945b..b54f743351a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,91 @@
# Maintainer: Patrick Desaulniers <patrick dot desaulniers36 at gmail dot com>
-pkgname=wolf-shaper-git
-pkgver=0.1.8.r62.g6b1ac64
+_pkgname=wolf-shaper
+_pkgdesc="A waveshaper plugin with graph editor"
+pkgname=$_pkgname-git
+pkgver=1.0.2.r22.gd34289f
pkgrel=1
-pkgdesc="Waveshaper plugin w/ graph editor"
-arch=('i686' 'x86_64')
-url="https://github.com/wolf-plugins/wolf-shaper"
-license=('GPL')
-depends=('libglvnd' 'libx11')
-makedepends=('dssi' 'lv2' 'jack')
-optdepends=('jack: for standalone application')
-provides=("${pkgname%-*}")
-conflicts=("${pkgname%-*}")
-source=("${pkgname%-*}::git+https://github.com/wolf-plugins/wolf-shaper")
+pkgdesc="$_pkgdesc (git version)"
+arch=(i686 x86_64)
+url='https://github.com/wolf-plugins/wolf-shaper'
+license=(GPL)
+groups=(
+ pro-audio
+ dssi-plugins
+ clap-plugins
+ lv2-plugins
+ vst-plugins
+ vst3-plugins
+)
+depends=(
+ gcc-libs
+ glibc
+ libxext
+ libglvnd
+ libx11
+)
+makedepends=(
+ alsa-lib
+ dssi
+ gcc-libs
+ gendesk
+ glibc
+ jack
+ liblo
+ libglvnd
+ libx11
+ libxext
+ lv2
+)
+optdepends=(
+ 'jack: for standalone application'
+ 'dssi-host: for loading the DSSI format plugin'
+ 'clap-host: for loading the CLAP format plugin'
+ 'lv2-host: for loading the LV2 format plugin'
+ 'vst-host: for loading the VST2 format plugin'
+ 'vst3-host: for loading the VST3 format plugin'
+)
+provides=(
+ $_pkgname{,-clap,-dssi,-lv2,-standalone,-vst,-vst3}
+)
+conflicts=(
+ $_pkgname{,-clap,-dssi,-lv2,-standalone,-vst,-vst3}
+)
+source=("$_pkgname::git+https://github.com/wolf-plugins/wolf-shaper")
md5sums=('SKIP')
pkgver() {
- cd "${pkgname%-*}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $_pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${pkgname%-*}"
- git submodule update --init --recursive
+ cd $_pkgname
+ git submodule update --init --recursive
+
+ gendesk -n \
+ --pkgname com.github.pdesaulniers.$_pkgname \
+ --name $_pkgname \
+ --exec $_pkgname \
+ --pkgdesc "$_pkgdesc" \
+ --genericname "Wave Shaper" \
+ --categories "AudioVideo;Audio"
}
build() {
- cd "${pkgname%-*}"
- make BUILD_DSSI=true BUILD_LV2=true BUILD_VST2=true BUILD_JACK=true
+ cd $_pkgname
+ make \
+ BUILD_CLAP=True \
+ BUILD_DSSI=true \
+ BUILD_JACK=true \
+ BUILD_LV2=true \
+ BUILD_VST2=true \
+ BUILD_VST3=True
}
package() {
- cd "${pkgname%-*}"
- make DESTDIR="$pkgdir" PREFIX="/usr" VST_FOLDER_NAME=vst install
+ depends+=(libasound.so libGL.so liblo.so)
+ cd $_pkgname
+ make DESTDIR="$pkgdir" PREFIX="/usr" VST_FOLDER_NAME=vst install
+ install -vDm 644 *.desktop -t "$pkgdir"/usr/share/applications
}