summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Popov2015-07-02 01:47:47 +0200
committerDenys Popov2015-07-02 01:47:47 +0200
commit64aa5093f67f18eeb0b001ced202df2edd8c3614 (patch)
tree11b5807ca97c40d5ad526defb53822ada1486b82
downloadaur-64aa5093f67f18eeb0b001ced202df2edd8c3614.tar.gz
Import from old AUR
-rw-r--r--.SRCINFO28
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD51
-rw-r--r--dosbox-install.conf5
-rw-r--r--dosbox.conf5
-rwxr-xr-xrunme4
-rw-r--r--setup.cfg3
-rw-r--r--wolfenstein3d.desktop8
8 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1eaeb90d2129
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = wolfenstein3d
+ pkgdesc = Wolfenstein 3D, cult first person shooter video game from id Software and Apogee
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://www.idsoftware.com/games/wolfenstein/wolf3d/
+ arch = any
+ license = custom
+ makedepends = unzip
+ depends = dosbox
+ source = LICENSE
+ source = ftp://ftp.3drealms.com/share/1wolf14.zip
+ source = setup.cfg
+ source = dosbox-install.conf
+ source = dosbox.conf
+ source = runme
+ source = wolfenstein3d.desktop
+ source = http://www.gamesprays.com/images/icons/wolfenstein-3d-mechahitler-animated-spray-1806_preview.png
+ sha256sums = daf535328cb428bba937ffde5db99db18f2b9eac338cb213f8ea1dda7e2f8d9e
+ sha256sums = cb2a2ef7ecef14152c65ff93cc3b84fbd3e8eb0c5c1de41a6fc8cdef559451a8
+ sha256sums = 6aaa1aa340338149ac104f66db998ccb7cebdf14db4fc24d2d51a8fa192e10b0
+ sha256sums = bd10ed1e5d0017e10dbd949cd3d6180f6210c6b795962e355a46c8eb46dc9558
+ sha256sums = 5a3c5e5a5d65614d90b92174f4318cee5631ec9fbaeda480d8740b79f145a422
+ sha256sums = eaa4ff9fb046685a38e368dbd70424d3ec3660f85e02cbbe4099b909f9a7a804
+ sha256sums = ecc61d3754c7a1c2d7547f029f5b456e3efafcbb73b30d843287905b48ead1d6
+ sha256sums = 23d898edb45cbd0c64a155592e84f27495848ab147faafa65bf4dffb1223d4ce
+
+pkgname = wolfenstein3d
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..faa8a87e00df
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,8 @@
+This game was made by id Software and distributed by Apogee (3D Realms). Copyright belongs to its respectful owners.
+
+The 1st episode is distributed as shareware by 3D Realms via their website: http://www.3drealms.com/wolf3d/
+Their licensing terms apply.
+
+Note from 3D Realms to German residents:
+ Due to the game content, this game may not be ordered by residents of Germany.
+ Please note that we are legally prohibited by German law from selling this item to any address in Germany. If you order this, your order will be cancelled. Thank you.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb3d015b0f77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: Denys Popov <besisland@besisland.name>
+
+pkgname=wolfenstein3d
+pkgver=1.4
+pkgrel=1
+pkgdesc="Wolfenstein 3D, cult first person shooter video game from id Software and Apogee"
+arch=(any)
+url="http://www.idsoftware.com/games/wolfenstein/wolf3d/"
+license=('custom')
+depends=('dosbox')
+makedepends=('unzip')
+source=(\
+ 'LICENSE'
+ 'ftp://ftp.3drealms.com/share/1wolf14.zip' \
+ 'setup.cfg' \
+ 'dosbox-install.conf' \
+ 'dosbox.conf' \
+ 'runme' \
+ 'wolfenstein3d.desktop' \
+ 'http://www.gamesprays.com/images/icons/wolfenstein-3d-mechahitler-animated-spray-1806_preview.png' \
+)
+sha256sums=(\
+ 'daf535328cb428bba937ffde5db99db18f2b9eac338cb213f8ea1dda7e2f8d9e' \
+ 'cb2a2ef7ecef14152c65ff93cc3b84fbd3e8eb0c5c1de41a6fc8cdef559451a8' \
+ '6aaa1aa340338149ac104f66db998ccb7cebdf14db4fc24d2d51a8fa192e10b0' \
+ 'bd10ed1e5d0017e10dbd949cd3d6180f6210c6b795962e355a46c8eb46dc9558' \
+ '5a3c5e5a5d65614d90b92174f4318cee5631ec9fbaeda480d8740b79f145a422' \
+ 'eaa4ff9fb046685a38e368dbd70424d3ec3660f85e02cbbe4099b909f9a7a804' \
+ 'ecc61d3754c7a1c2d7547f029f5b456e3efafcbb73b30d843287905b48ead1d6' \
+ '23d898edb45cbd0c64a155592e84f27495848ab147faafa65bf4dffb1223d4ce' \
+)
+
+build() {
+ cd "${srcdir}"
+
+ mkdir install
+ mkdir install/wolf3d
+ unzip 1wolf14.zip -d install
+ cp setup.cfg install/
+ dosbox -conf dosbox-install.conf
+
+ install -d ${pkgdir}/opt/wolfenstein3d
+ install -m 0644 install/wolf3d/* ${pkgdir}/opt/wolfenstein3d/
+ install -m 0644 dosbox.conf ${pkgdir}/opt/wolfenstein3d/dosbox.conf
+ install -m 0755 runme ${pkgdir}/opt/wolfenstein3d/runme
+
+ install -D -m 0644 wolfenstein3d.desktop ${pkgdir}/usr/share/applications/wolfenstein3d.desktop
+ install -D -m 0644 wolfenstein-3d-mechahitler-animated-spray-1806_preview.png ${pkgdir}/usr/share/pixmaps/wolfenstein3d.png
+
+ install -D -m 0644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/dosbox-install.conf b/dosbox-install.conf
new file mode 100644
index 000000000000..b161da9b3233
--- /dev/null
+++ b/dosbox-install.conf
@@ -0,0 +1,5 @@
+[autoexec]
+mount c install
+c:
+install setup.cfg
+exit
diff --git a/dosbox.conf b/dosbox.conf
new file mode 100644
index 000000000000..27b0e4f63617
--- /dev/null
+++ b/dosbox.conf
@@ -0,0 +1,5 @@
+[autoexec]
+mount c ~/.wolf3d
+c:
+wolf3d
+exit
diff --git a/runme b/runme
new file mode 100755
index 000000000000..b478025e3ac5
--- /dev/null
+++ b/runme
@@ -0,0 +1,4 @@
+#!/bin/sh
+mkdir -p ~/.wolf3d
+for file in /opt/wolfenstein3d/*; do ln -s $file ~/.wolf3d/`basename $file`; done
+dosbox -conf ~/.wolf3d/dosbox.conf
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 000000000000..a90ddc48600c
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,3 @@
+TITLE: "Wolfenstein 3D v1.4 Shareware Episode"
+DEFAULTDIR: "C:\WOLF3D", noaskdrive, noaskdir
+FILE: "w3dsw14.shr", overwrite=yes
diff --git a/wolfenstein3d.desktop b/wolfenstein3d.desktop
new file mode 100644
index 000000000000..77c3df076012
--- /dev/null
+++ b/wolfenstein3d.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Wolfenstein 3D
+Comment=Cult 1992 first person shooter
+Exec=/opt/wolfenstein3d/runme
+Icon=wolfenstein3d.png
+Type=Application
+Terminal=false
+Categories=Game;