summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-11 16:52:33 +0100
committerNarrat2020-01-11 16:52:33 +0100
commiteebabf13c470fcd6dbeb28ab08472269aa4ef4fb (patch)
tree4ce5f2b6d1353a278685ba88573fdc6c2230f900
parent4dedba9ba96cec35ba95c50e247b637c4cc34df0 (diff)
downloadaur-eebabf13c470fcd6dbeb28ab08472269aa4ef4fb.tar.gz
update to 4.3.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1527e69f6c48..7de161f8c9fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = wolfssl
- pkgdesc = A small, fast, portable implementation of TLS/SSL for embedded devices to the cloud. (formerly CyaSSL)
- pkgver = 3.12.0
- pkgrel = 3
+ pkgdesc = small, fast, portable implementation of TLS/SSL for embedded devices to the cloud (formerly CyaSSL)
+ pkgver = 4.3.0
+ pkgrel = 1
url = https://www.wolfssl.com/
arch = i686
arch = x86_64
license = GPL
- depends = bash
- source = https://github.com/wolfSSL/wolfssl/archive/v3.12.0-stable.tar.gz
- sha256sums = 5045f6dc4221a8cf4fa993d020dda0886be4028d0e2cefbf9713b58f6eb0e635
+ depends = sh
+ source = wolfssl-4.3.0-stable.tar.gz::https://github.com/wolfSSL/wolfssl/archive/v4.3.0-stable.tar.gz
+ source = https://github.com/wolfSSL/wolfssl/releases/download/v4.3.0-stable/wolfssl-4.3.0-stable.tar.gz.asc
+ validpgpkeys = EBC80E415CA29677
+ sha256sums = 6896f8ad6c44aff3e583006eeee839600848a0e37118ebbb7514eca9409ae08b
+ sha256sums = SKIP
pkgname = wolfssl
diff --git a/PKGBUILD b/PKGBUILD
index be43d34bec37..03591895b7f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,20 @@
-# Maintainer: Maxime Vincent <maxime.vince@gmail.com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Maxime Vincent <maxime.vince@gmail.com>
pkgname=wolfssl
-pkgver=3.12.0
-pkgrel=3
-pkgdesc='A small, fast, portable implementation of TLS/SSL for embedded devices to the cloud. (formerly CyaSSL) '
+pkgver=4.3.0
+pkgrel=1
+pkgdesc='small, fast, portable implementation of TLS/SSL for embedded devices to the cloud (formerly CyaSSL)'
arch=(i686 x86_64)
license=(GPL)
-depends=('bash')
+depends=('sh')
url='https://www.wolfssl.com/'
-source=(https://github.com/wolfSSL/wolfssl/archive/v$pkgver-stable.tar.gz)
-sha256sums=('5045f6dc4221a8cf4fa993d020dda0886be4028d0e2cefbf9713b58f6eb0e635')
+source=(${pkgname}-${pkgver}-stable.tar.gz::https://github.com/wolfSSL/wolfssl/archive/v$pkgver-stable.tar.gz
+ https://github.com/wolfSSL/wolfssl/releases/download/v${pkgver}-stable/${pkgname}-${pkgver}-stable.tar.gz.asc)
+sha256sums=('6896f8ad6c44aff3e583006eeee839600848a0e37118ebbb7514eca9409ae08b'
+ 'SKIP')
+validpgpkeys=('EBC80E415CA29677')
+
build() {
cd $pkgname-$pkgver-stable