summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFTS4272023-09-10 07:14:01 +0000
committerFTS4272023-09-10 07:14:01 +0000
commite2e8a40ca2e26f500aa79b3371cb84728dfd3383 (patch)
tree005577863ffdc5d4ed8f90b1c10d4db413f9c880
parentce3faebe41b0f4b64244f2bc38cf00a4608e0962 (diff)
downloadaur-e2e8a40ca2e26f500aa79b3371cb84728dfd3383.tar.gz
Upload
-rw-r--r--PKGBUILD25
1 files changed, 8 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f94be2821e7e..e81218697d80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,33 +25,24 @@ prepare() {
}
build() {
- sed -i -E \
- "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${_pkgname}|" \
- "squashfs-root/blessing.${_pkgname}.desktop"
+ sed -i -E "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${_pkgname}|" "squashfs-root/blessing.${_pkgname}.desktop"
+ sed -i 's/Terminal=true/Terminal=false/g' ./squashfs-root/blessing.${_pkgname}.desktop
# Fix permissions; .AppImage permissions are 700 for all directories
chmod -R a-x+rX squashfs-root/usr
}
package() {
# AppImage
- install -Dm755 \
- "${srcdir}/${_appimage}" \
- "${pkgdir}/opt/${_pkgname}/${_pkgname}.AppImage"
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${_pkgname}/${_pkgname}.AppImage"
- # Desktop file
- install -Dm644 \
- "${srcdir}/squashfs-root/blessing.${_pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ # Desktop
+ install -Dm644 "${srcdir}/squashfs-root/blessing.${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- # Icon images
+ # Icon
install -dm755 "${pkgdir}/usr/share/"
- cp -a \
- "${srcdir}/squashfs-root/usr/share/icons" \
- "${pkgdir}/usr/share/"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
# Symlink executable
install -dm755 "${pkgdir}/usr/bin"
- ln -s \
- "/opt/${_pkgname}/${_pkgname}.AppImage" \
- "${pkgdir}/usr/bin/${_pkgname}"
+ ln -s "/opt/${_pkgname}/${_pkgname}.AppImage" "${pkgdir}/usr/bin/${_pkgname}"
}