summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMCSeekeri2023-01-30 00:55:36 +0800
committerMCSeekeri2023-01-30 00:55:36 +0800
commit11b424423f221a003d02186378fa8446b6fe8e7d (patch)
tree36b42d849dbff72430e9b4d42b4d298f0ca75cb3
downloadaur-11b424423f221a003d02186378fa8446b6fe8e7d.tar.gz
First commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--wonderlab.desktop9
-rw-r--r--wonderlab.pngbin0 -> 31101 bytes
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33eb29fff60e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wonderlab-git
+ pkgdesc = 下一代跨平台 Minecraft 启动器
+ pkgver = 1.0.1.6
+ pkgrel = 1
+ url = https://github.com/Blessing-Studio/WonderLab
+ arch = x86_64
+ license = MIT
+ makedepends = dotnet-sdk-6.0
+ depends = dotnet-runtime-6.0
+ options = !strip
+ options = !emptydirs
+ source = WonderLab-1.0.1.6.tar.gz::https://github.com/Blessing-Studio/WonderLab/archive/refs/heads/master.zip
+ source = wonderlab.desktop
+ source = wonderlab.png
+ sha512sums = SKIP
+ sha512sums = 9501b7df25f72e38a7e62fec7df3565116cb365e6e2732b3bbf828dd3afdf094797c4ccdb4764ad9b37a69609ff86baeafe4ca14aace6f0c78dd55f8bdd0d666
+ sha512sums = 346c7db149086ae0baab3b5675a0fc540926b76783f0aa86f0f58754be6eefeb58c408e82416b6f3d12ccc45f68ee2b770e7be3aad29d77b5fe44e697873d137
+
+pkgname = wonderlab-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a47628dde0ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: MCSeekeri <mcseekeri@outlook.com>
+pkgname=wonderlab-git
+_pkgname=WonderLab
+pkgver=1.0.1.6
+pkgrel=1
+epoch=
+pkgdesc="下一代跨平台 Minecraft 启动器"
+arch=('x86_64')
+url="https://github.com/Blessing-Studio/WonderLab"
+groups=()
+license=('MIT')
+depends=('dotnet-runtime-6.0')
+makedepends=('dotnet-sdk-6.0')
+options=('!strip' '!emptydirs')
+source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/refs/heads/master.zip" wonderlab.desktop wonderlab.png)
+sha512sums=('SKIP' 9501b7df25f72e38a7e62fec7df3565116cb365e6e2732b3bbf828dd3afdf094797c4ccdb4764ad9b37a69609ff86baeafe4ca14aace6f0c78dd55f8bdd0d666 346c7db149086ae0baab3b5675a0fc540926b76783f0aa86f0f58754be6eefeb58c408e82416b6f3d12ccc45f68ee2b770e7be3aad29d77b5fe44e697873d137)
+
+build() {
+ cd "$_pkgname-master"
+ dotnet build --configuration Release
+}
+
+package(){
+
+ cd "$_pkgname-master"
+ mkdir -p "${pkgdir}/usr/share/WonderLab"
+ mkdir -p "${pkgdir}/usr/share/icons/"
+ cp -a WonderLab/bin/Release/net6.0/* "${pkgdir}/usr/share/WonderLab"
+ rm -rf "${pkgdir}/usr/share/WonderLab/runtimes"
+ install -Dm644 "../wonderlab.png" "${pkgdir}/usr/share/icons/wonderlab.png"
+ install -Dm755 'WonderLab/bin/Release/net6.0/WonderLab' "$pkgdir/usr/local/bin/$_pkgname"
+ install -Dm644 "../wonderlab.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ cd ..
+
+}
diff --git a/wonderlab.desktop b/wonderlab.desktop
new file mode 100644
index 000000000000..6aa4a157e700
--- /dev/null
+++ b/wonderlab.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=WonderLab
+Type=Application
+Terminal=false
+Exec=/usr/share/wonderlab/wonderlab
+Icon=/usr/share/icons/wonderlab.png
+Categories=Game;ActionGame;AdventureGame;Simulation;
+Keywords=game;minecraft;launcher;mc;
+Comment[zh_CN]=下一代跨平台 Minecraft 启动器 \ No newline at end of file
diff --git a/wonderlab.png b/wonderlab.png
new file mode 100644
index 000000000000..e2f3a43a01d9
--- /dev/null
+++ b/wonderlab.png
Binary files differ