summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUgis Germanis2015-08-31 19:27:22 +0300
committerUgis Germanis2015-08-31 19:27:22 +0300
commitbe2fd3c41f2b4b2489781798535c5e4de6f38d66 (patch)
tree7b17ba118b03feab6487844f048498d5802d7052
downloadaur-be2fd3c41f2b4b2489781798535c5e4de6f38d66.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..549f114c7d83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = wondershaper-git
+ pkgdesc = network adapter bandwidth limiter
+ pkgver = 20130114
+ pkgrel = 1
+ url = https://github.com/magnific0/wondershaper.git
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = iproute
+
+pkgname = wondershaper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e81a5dc4383
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer ugjka <ugis.germanis@gmmail.com>
+# Contributor: Bill Sun <billksun@gmail.com>
+# Contributor magnific0
+pkgname=wondershaper-git
+pkgver=20130114
+pkgrel=1
+pkgdesc="network adapter bandwidth limiter"
+arch=('x86_64' 'i686')
+url="https://github.com/magnific0/wondershaper.git"
+license=('GPL2')
+depends=('iproute')
+_gitroot="git://github.com/magnific0/wondershaper.git"
+_gitname="wondershaper"
+
+build() {
+ cd "$srcdir"
+
+ msg "Connecting to the git repository..."
+ if [ -d "$srcdir/$_gitname" ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ cd "$srcdir"
+ rm -rf $_gitname-build
+ git clone $_gitname $_gitname-build
+ cd $_gitname-build
+
+ make
+
+}
+
+package() {
+ cd $_gitname-build
+
+ install -Dm755 wondershaper "$pkgdir/usr/bin/wondershaper"
+
+}
+
+# vim:set ts=2 sw=2 et: