summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2019-02-22 18:12:38 +0100
committerFrederik “Freso” S. Olesen2019-02-22 18:13:22 +0100
commit59a91314aceac822750e6d52bb691ab6f57361ea (patch)
tree7f07b19c19e335cec50949abc3e481bccb929c9b
parentfa5d1c00faff54d0641eb626900bbf11a84b27f6 (diff)
downloadaur-59a91314aceac822750e6d52bb691ab6f57361ea.tar.gz
Update udev rules
As per https://wooting.helpscoutdocs.com/article/34-linux-udev-rules
-rw-r--r--.SRCINFO4
-rw-r--r--70-wooting.rules18
-rw-r--r--PKGBUILD4
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06c5a9d5c15a..5bf5d5646ed9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wootility-appimage
pkgdesc = Utility for configuring Wooting keyboards (binary AppImage version)
pkgver = 3.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://wooting.io/wootility
arch = x86_64
license = unknown
@@ -13,7 +13,7 @@ pkgbase = wootility-appimage
source = https://s3.eu-west-2.amazonaws.com/wooting-update/wootility-linux-latest/wootility-3.0.2-x86_64.AppImage
source = 70-wooting.rules
sha512sums = e0f41a7b1c0cf93fed2f017589452870f532541d351cf3568d44fc271b9ccec2741c397198c602c50c27a5b228dfd858bf42d9e38f544e4a0c45a0f845f4f213
- sha512sums = 3eddcccc40a6ddc924777ced27e757f966889bf789b312ec87c7ba76e69362f14231a5559b86259eb641e5cf1d14333c23fb344a3d278870ba6843fc5dff6579
+ sha512sums = d150e8825cc2254997745fd7a61afd65b05415d694d02d580197b4e3497e64da6261d4fb919a670917379ca1c813416478c2660fe4044e5138a69087ea31ce8d
pkgname = wootility-appimage
diff --git a/70-wooting.rules b/70-wooting.rules
index e7f254b7195c..c6b197168f62 100644
--- a/70-wooting.rules
+++ b/70-wooting.rules
@@ -1,3 +1,17 @@
SUBSYSTEM=="input", GROUP="input", MODE="0660"
-SUBSYSTEM=="usb", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff01", TAG+="uaccess"
-SUBSYSTEM=="usb", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2402", TAG+="uaccess"
+
+# Wooting One
+SUBSYSTEM=="usb*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff01", TAG+="uaccess"
+SUBSYSTEM=="hid*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff01", TAG+="uaccess"
+
+# Wooting One update mode
+SUBSYSTEM=="usb*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2402", TAG+="uaccess"
+SUBSYSTEM=="hid*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2402", TAG+="uaccess"
+
+# Wooting Two
+SUBSYSTEM=="usb*", ATTRS{idVendor}=="02eb", ATTRS{idProduct}=="ff02", TAG+="uaccess"
+SUBSYSTEM=="hid*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff02", TAG+="uaccess"
+
+# Wooting Two update mode
+SUBSYSTEM=="usb*", ATTRS{idVendor}=="02eb", ATTRS{idProduct}=="2403", TAG+="uaccess"
+SUBSYSTEM=="hid*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2403", TAG+="uaccess"
diff --git a/PKGBUILD b/PKGBUILD
index 5502cd63a3ea..575970fceeb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=wootility
pkgname=${_pkgname}-appimage
pkgver=3.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='Utility for configuring Wooting keyboards (binary AppImage version)'
arch=('x86_64')
url='https://wooting.io/wootility'
@@ -16,7 +16,7 @@ source=("https://s3.eu-west-2.amazonaws.com/wooting-update/wootility-linux-lates
'70-wooting.rules')
noextract=("${_appimage}")
sha512sums=('e0f41a7b1c0cf93fed2f017589452870f532541d351cf3568d44fc271b9ccec2741c397198c602c50c27a5b228dfd858bf42d9e38f544e4a0c45a0f845f4f213'
- '3eddcccc40a6ddc924777ced27e757f966889bf789b312ec87c7ba76e69362f14231a5559b86259eb641e5cf1d14333c23fb344a3d278870ba6843fc5dff6579')
+ 'd150e8825cc2254997745fd7a61afd65b05415d694d02d580197b4e3497e64da6261d4fb919a670917379ca1c813416478c2660fe4044e5138a69087ea31ce8d')
prepare() {
7z x "${_appimage}" 'wootility.desktop' 'usr/share/icons' > /dev/null