summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShayne Hartford2021-05-08 22:58:53 -0400
committerShayne Hartford2021-05-08 22:58:53 -0400
commitdc4264c3218e2041c9e9958f1700bad12e851c95 (patch)
tree68a8d32774ef4c9cc9351a1bb83c3e7403ebd14b
parentff5f003d90d4e64b6d91c7cb694628e75fb36e00 (diff)
downloadaur-dc4264c3218e2041c9e9958f1700bad12e851c95.tar.gz
Add depends, makedepends, switch to make install
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc63cf149863..ba3a309c91eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,10 @@ pkgbase = wooting-rgb-sdk-git
url = https://github.com/WootingKb/wooting-rgb-sdk
arch = any
license = MPL2
+ makedepends = git
+ makedepends = hidapi
+ makedepends = libusb
+ depends = libusb
provides = wooting-rgb-sdk
source = git+https://github.com/WootingKb/wooting-rgb-sdk.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b60935a03231..9408c5240e7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,8 @@ pkgdesc="Customize colors on Wooting Keyboard #WootDev"
arch=('any')
url="https://github.com/WootingKb/$_pkgname"
license=('MPL2')
-
+depends=('libusb')
+makedepends=('git' 'hidapi' 'libusb')
provides=($_pkgname)
source=("git+$url.git")
md5sums=("SKIP")
@@ -19,17 +20,8 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd "$srcdir/$_pkgname/linux"
-
- make CFLAGS='-Wall -g -fPIC'
-}
-
package() {
cd "$srcdir/$_pkgname/linux"
- install -Dm644 libwooting-rgb-sdk.pc $pkgdir/usr/local/lib/pkgconfig/libwooting-rgb-sdk.pc
- install -Dm644 libwooting-rgb-sdk.so $pkgdir/usr/local/lib/libwooting-rgb-sdk.so
- install -Dm644 ../src/wooting-rgb-sdk.h $pkgdir/usr/local/include/wooting-rgb-sdk.h
- install -Dm644 ../src/wooting-usb.h $pkgdir/usr/local/include/wooting-usb.h
+ CFLAGS+=" -fPIC" prefix="$pkgdir/usr" make install
}