summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShayne Hartford2021-05-08 15:49:13 -0400
committerShayne Hartford2021-05-08 15:49:13 -0400
commitff5f003d90d4e64b6d91c7cb694628e75fb36e00 (patch)
tree116f015b9ffb88b910e49f3f92160875ecd76cef
downloadaur-ff5f003d90d4e64b6d91c7cb694628e75fb36e00.tar.gz
Upload package
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc63cf149863
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = wooting-rgb-sdk-git
+ pkgdesc = Customize colors on Wooting Keyboard #WootDev
+ pkgver = r102.5da2ac1
+ pkgrel = 1
+ url = https://github.com/WootingKb/wooting-rgb-sdk
+ arch = any
+ license = MPL2
+ provides = wooting-rgb-sdk
+ source = git+https://github.com/WootingKb/wooting-rgb-sdk.git
+ md5sums = SKIP
+
+pkgname = wooting-rgb-sdk-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b60935a03231
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Shayne Hartford <shayneehartford@gmail.com>
+
+_pkgname=wooting-rgb-sdk
+pkgname=${_pkgname}-git
+pkgver=r102.5da2ac1
+pkgrel=1
+pkgdesc="Customize colors on Wooting Keyboard #WootDev"
+arch=('any')
+url="https://github.com/WootingKb/$_pkgname"
+license=('MPL2')
+
+provides=($_pkgname)
+source=("git+$url.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname/linux"
+
+ make CFLAGS='-Wall -g -fPIC'
+}
+
+package() {
+ cd "$srcdir/$_pkgname/linux"
+
+ install -Dm644 libwooting-rgb-sdk.pc $pkgdir/usr/local/lib/pkgconfig/libwooting-rgb-sdk.pc
+ install -Dm644 libwooting-rgb-sdk.so $pkgdir/usr/local/lib/libwooting-rgb-sdk.so
+ install -Dm644 ../src/wooting-rgb-sdk.h $pkgdir/usr/local/include/wooting-rgb-sdk.h
+ install -Dm644 ../src/wooting-usb.h $pkgdir/usr/local/include/wooting-usb.h
+}