summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben Schweren2023-02-25 04:05:23 +0100
committerTorben Schweren2023-02-25 04:05:23 +0100
commit7f0ad21ca9f874c36a1f3d620f74698ddbfb37a3 (patch)
tree6772365cb87854a823df0f517d04907ccc6a2fef
downloadaur-7f0ad21ca9f874c36a1f3d620f74698ddbfb37a3.tar.gz
Set up AUR package
Added PKGBUILD Added .SRCINFO Added wootomation.install
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD56
-rw-r--r--wootomation.install13
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..362fa90eedca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wootomation-appimage
+ pkgdesc = A macro application by Wooting. (AppImage version)
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/WootingKb/wooting-macros
+ install = wootomation.install
+ arch = x86_64
+ license = GPL3
+ options = !strip
+ source = https://github.com/WootingKb/wooting-macros/releases/download/v1.0.2/wootomation_1.0.2_amd64.AppImage
+ source = wootomation.install
+ md5sums = 8ad1843421d29c20d46c1e62a442cf6f
+ md5sums = 10a101af0f9b1c08996eade78f8e30e7
+
+pkgname = wootomation-appimage
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5ae6d787455
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.AppImage
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39240cc10952
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Torben Schweren <torben@schweren.dev>
+# I copied some things over from Shayne Hartford's PKGBUILD for Wootility: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=wootility-lekker-appimage
+pkgname=wootomation-appimage
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A macro application by Wooting. (AppImage version)"
+arch=('x86_64')
+url="https://github.com/WootingKb/wooting-macros"
+license=('GPL3')
+#
+release=${pkgver}
+appname=wootomation
+filename=${appname}_${pkgver}_amd64.AppImage
+inappimage_binaryname=${appname}
+inappimage_desktopname=${appname}.desktop
+inappimage_iconname=${appname}.png
+#depends=('fuse2')
+#makedepends=()
+#checkdepends=()
+#optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=(!strip)
+install=${appname}.install
+#changelog=
+source=(
+ "https://github.com/WootingKb/wooting-macros/releases/download/v$pkgver/${filename}"
+ "wootomation.install"
+)
+#noextract=()
+md5sums=(
+ "8ad1843421d29c20d46c1e62a442cf6f"
+ "10a101af0f9b1c08996eade78f8e30e7"
+)
+#validpgpkeys=()
+
+prepare() {
+ chmod +x ./${filename}
+ ./${filename} --appimage-extract usr/bin/${inappimage_binaryname}
+ ./${filename} --appimage-extract ${inappimage_desktopname}
+ ./${filename} --appimage-extract ${inappimage_iconname}
+ ./${filename} --appimage-extract usr/share/icons
+}
+
+
+#build() {}
+
+#check() {}
+
+package() {
+ install -Dpm755 "squashfs-root/usr/bin/${inappimage_binaryname}" "${pkgdir}/usr/bin/${inappimage_binaryname}" # Install the binary from the AppImage to the host
+ install -Dpm644 "squashfs-root/${inappimage_desktopname}" "${pkgdir}/usr/share/applications/${inappimage_desktopname}" # Installs the .desktop file from the AppImage to the host
+ install -Dpm644 "squashfs-root/${inappimage_iconname}" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${inappimage_iconname}" # Installs the icon from the AppImage to the host
+}
diff --git a/wootomation.install b/wootomation.install
new file mode 100644
index 000000000000..24aa6da8eb49
--- /dev/null
+++ b/wootomation.install
@@ -0,0 +1,13 @@
+# This file was taken from Shayne Hartford's Wootility AUR package (https://aur.archlinux.org/packages/wootility-lekker-appimage) and modified
+post() {
+ echo "You must add yourself to the 'input' group for wootomation to work correctly, 'sudo usermod -aG input <username>'"
+ echo "You must restart your login session to apply group changes (logout or reboot)"
+}
+
+post_install() {
+ post
+}
+
+post_upgrade() {
+ post
+}