summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Harrison2023-11-08 13:17:09 -0500
committerMatt Harrison2023-11-08 13:17:09 -0500
commitbe1a172677745f2772054bc1ff2d84f8031358a6 (patch)
treef7be9cf714484ccb26eb57b2f09fab51aee5f435
downloadaur-be1a172677745f2772054bc1ff2d84f8031358a6.tar.gz
Initial upload: wordfence-cli 2.0.3-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dee11a33fb8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wordfence-cli
+ pkgdesc = A modern and fast real-time MIDI player written in Rust.
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://github.com/wordfence/wordfence-cli
+ arch = any
+ license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = python
+ depends = python-packaging
+ depends = python-requests
+ source = wordfence-cli-2.0.3.tar.gz::https://github.com/wordfence/wordfence-cli/archive/refs/tags/v2.0.3.tar.gz
+ b2sums = d31fc3b368005933190fbd543fcd88b6100c356bb07c7e3202f844b38d8439ef02c83741ff8e7b520d90a4687c74b85a155f382e3b51427921bb3323c1d56c6e
+
+pkgname = wordfence-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a43f79c5daf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Matt Harrison <matt@harrison.us.com>
+# Maintained at: https://github.com/matt-h/aur-pkgbuilds or https://codeberg.org/matt/aur-pkgbuilds
+
+pkgname=wordfence-cli
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="A modern and fast real-time MIDI player written in Rust."
+url="https://github.com/wordfence/wordfence-cli"
+arch=('any')
+license=('GPL3')
+depends=(python python-packaging python-requests)
+makedepends=(python-build python-installer python-wheel python-setuptools)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wordfence/wordfence-cli/archive/refs/tags/v$pkgver.tar.gz")
+b2sums=('d31fc3b368005933190fbd543fcd88b6100c356bb07c7e3202f844b38d8439ef02c83741ff8e7b520d90a4687c74b85a155f382e3b51427921bb3323c1d56c6e')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}