summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kuehn2024-06-13 01:49:35 -0400
committerDaniel Kuehn2024-06-13 01:49:35 -0400
commit347fd5ff61c29cdcb90277d0e597fbc0a6a1afb0 (patch)
tree3e99a84fbce0c6c4e90874449a1c109c46764366
parent024e1205527964f35c245568493662b72aca81c6 (diff)
downloadaur-347fd5ff61c29cdcb90277d0e597fbc0a6a1afb0.tar.gz
v0.1.0
- https://github.com/wordgen/cli/releases/tag/v0.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe88ef5715df..79bfad3997f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = wordgen
pkgdesc = A CLI program that prints random words generated from the EFF Large Wordlist.
- pkgver = 1.0.0
- pkgrel = 2
- url = https://github.com/danny-kuehn/wordgen
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/wordgen/cli
arch = x86_64
license = AGPL-3.0-or-later
makedepends = go
options = !debug
- source = https://github.com/danny-kuehn/wordgen/archive/v1.0.0.tar.gz
- sha256sums = aad62444915782d609c44e0c1bf6cfdf13638ca285a39ad888314f50770f43ed
+ source = https://github.com/wordgen/cli/archive/v0.1.0.tar.gz
+ sha256sums = df7fbfe648c054e1156ab31cc2f226302d150f37b7b6dfab87b3ebca30471158
pkgname = wordgen
diff --git a/PKGBUILD b/PKGBUILD
index c278d3971bce..13d28c5d6c00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Daniel Kuehn <daniel@kuehn.foo>
pkgname=wordgen
-pkgver=1.0.0
-pkgrel=2
+pkgver=0.1.0
+pkgrel=1
pkgdesc="A CLI program that prints random words generated from the EFF Large Wordlist."
arch=('x86_64')
-url="https://github.com/danny-kuehn/$pkgname"
+url="https://github.com/wordgen/cli"
license=('AGPL-3.0-or-later')
makedepends=('go')
options=(!debug)
source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('aad62444915782d609c44e0c1bf6cfdf13638ca285a39ad888314f50770f43ed')
+sha256sums=('df7fbfe648c054e1156ab31cc2f226302d150f37b7b6dfab87b3ebca30471158')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/cli-$pkgver"
- go build -o "bin/$pkgname" -trimpath -ldflags="-s -w -X main.version=$pkgver -buildid=" ./cmd/wordgen
+ go build -o "bin/$pkgname" -trimpath -ldflags="-s -w -X main.version=$pkgver -buildid=" .
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/cli-$pkgver"
install -Dm755 "bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"