summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-08-11 09:30:46 +0200
committeraksr2016-08-11 09:30:46 +0200
commitf32f3b6143f7e1994bfad0990385f14b474c26d7 (patch)
tree43293bc3abb2589d73b06eeaddcf494dcde1de2e
downloadaur-f32f3b6143f7e1994bfad0990385f14b474c26d7.tar.gz
Start.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb2413d852cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Aug 11 07:30:45 UTC 2016
+pkgbase = wordgrinder-git
+ pkgdesc = A word processor which gets the hell out of your way and lets you get some work done.
+ pkgver = 0.6.r7.g0e2b004
+ pkgrel = 1
+ url = http://cowlark.com/wordgrinder
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ provides = wordgrinder
+ conflicts = wordgrinder
+ source = wordgrinder-git::git+https://github.com/davidgiven/wordgrinder.git
+ md5sums = SKIP
+
+pkgname = wordgrinder-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c3acc8924c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=wordgrinder-git
+pkgver=0.6.r7.g0e2b004
+pkgrel=1
+epoch=
+pkgdesc="A word processor which gets the hell out of your way and lets you get some work done."
+arch=('i686' 'x86_64')
+url="https://github.com/davidgiven/wordgrinder"
+url="http://cowlark.com/wordgrinder"
+license=('MIT')
+categories=()
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/davidgiven/wordgrinder.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make PREFIX="$pkgdir/usr" install
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/${pkgname%-*}/COPYING
+}
+