summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Fernandes2023-01-10 15:49:15 -0500
committerFilipe Fernandes2023-01-10 15:49:15 -0500
commit4be5a1f764933835ceec01324a72d3b6942b6140 (patch)
treebdd7e81760333268cabf80097ba225de47c4d258
parentff66c258f47141d871019296f4718b0d08d137c2 (diff)
downloadaur-4be5a1f764933835ceec01324a72d3b6942b6140.tar.gz
update mantainer and reference latest SecLists wordlist files.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b4dc56cfc03..ff76e62d3ef2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = wordlists
pkgdesc = Download a great set of wordlists. In /usr/share/wordlists
- pkgver = 0.2
+ pkgver = 0.3
pkgrel = 1
- url = https://github.com/5amu
arch = any
license = MIT
license = GPLv2
source = https://gitlab.com/kalilinux/packages/dirbuster/-/archive/kali/1.0-1kali4/dirbuster-kali-1.0-1kali4.tar.gz
source = https://gitlab.com/kalilinux/packages/dirb/-/archive/debian/2.22-0kali3/dirb-debian-2.22-0kali3.tar.gz
source = https://github.com/xmendez/wfuzz/archive/v3.1.0.tar.gz
- source = https://github.com/danielmiessler/SecLists/archive/2021.1.tar.gz
+ source = https://github.com/danielmiessler/SecLists/archive/2022.4.tar.gz
sha256sums = 32603661e7d8ac8e60dcd8f1a3cca732065720cc1a5a80f075509affcca8a4bf
sha256sums = 5c52611cf3b58b6e5855e7f3a6cf28da324ccf820d89920b89488d9b5bc1cba1
sha256sums = 60798e56274a377f8770d162935a040d4d6e27919bfbb46cf13a7a0a34896be9
- sha256sums = ac44e33bc388f954e077db90714a2eab5d2c65e67400dda8b998ca555f9eb74f
+ sha256sums = 3d61246b2f5405df97a3b4d962f299559091c2e40ccec6af8d820fe82093ece5
pkgname = wordlists
-
diff --git a/PKGBUILD b/PKGBUILD
index 80c0cd853e36..cb584e61993f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer 5amu <v.casalino@protonmail.com>
+# Maintainer filotek <fernandes.fd at gmail.com>
+# Contributor 5amu <v.casalino at protonmail.com>
pkgname=wordlists
-pkgver=0.2
+pkgver=0.3
pkgrel=1
pkgdesc="Download a great set of wordlists. In /usr/share/wordlists"
-url="https://github.com/5amu"
license=('MIT' 'GPLv2')
arch=('any')
source=(
"https://gitlab.com/kalilinux/packages/dirbuster/-/archive/kali/1.0-1kali4/dirbuster-kali-1.0-1kali4.tar.gz"
"https://gitlab.com/kalilinux/packages/dirb/-/archive/debian/2.22-0kali3/dirb-debian-2.22-0kali3.tar.gz"
- "https://github.com/xmendez/wfuzz/archive/v3.1.0.tar.gz"
- "https://github.com/danielmiessler/SecLists/archive/2021.1.tar.gz"
+ "https://github.com/xmendez/wfuzz/archive/refs/tags/v3.1.0.tar.gz"
+ "https://github.com/danielmiessler/SecLists/archive/refs/tags/2022.4.tar.gz"
)
sha256sums=(
"32603661e7d8ac8e60dcd8f1a3cca732065720cc1a5a80f075509affcca8a4bf"
"5c52611cf3b58b6e5855e7f3a6cf28da324ccf820d89920b89488d9b5bc1cba1"
"60798e56274a377f8770d162935a040d4d6e27919bfbb46cf13a7a0a34896be9"
- "ac44e33bc388f954e077db90714a2eab5d2c65e67400dda8b998ca555f9eb74f"
+ "3d61246b2f5405df97a3b4d962f299559091c2e40ccec6af8d820fe82093ece5"
)
prepare() {
@@ -36,7 +36,7 @@ package() {
cp -r $srcdir/wfuzz-3.1.0/wordlist/* $pkgdir/usr/share/wordlists/wfuzz
install -Dm644 $srcdir/wfuzz-3.1.0/LICENSE $pkgdir/usr/share/licenses/wordlists/wfuzz/LICENSE
mkdir -p $pkgdir/usr/share/wordlists/seclists
- cp -r $( find $srcdir/SecLists-2021.1/* -type d -maxdepth 0) $pkgdir/usr/share/wordlists/seclists
- install -Dm644 $srcdir/SecLists-2021.1/LICENSE $pkgdir/usr/share/licenses/wordlists/seclists/LICENSE
+ cp -r $( find $srcdir/SecLists-2022.4/* -maxdepth 0 -type d) $pkgdir/usr/share/wordlists/seclists
+ install -Dm644 $srcdir/SecLists-2022.4/LICENSE $pkgdir/usr/share/licenses/wordlists/seclists/LICENSE
find $pkgdir/usr/share/wordlists -type f -exec chmod 644 \{\} \;
}