summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Allen2015-06-09 12:02:29 -0400
committerSteven Allen2015-06-09 12:02:29 -0400
commit174fc60bf4b7507f9118257993d4ffee15207b08 (patch)
tree1a95c39369a9c949ecb7b84fcbae96c637602536
downloadaur-174fc60bf4b7507f9118257993d4ffee15207b08.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
-rw-r--r--wordnet.desktop12
-rw-r--r--wordnet.pngbin0 -> 2412 bytes
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f874bc8d61f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wordnet
+ pkgdesc = An Electronic Lexical Database from Princeton University
+ pkgver = 3.1
+ pkgrel = 1
+ url = http://wordnet.princeton.edu/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = tk
+ options = staticlibs
+ source = http://wordnetcode.princeton.edu/3.0/WordNet-3.0.tar.bz2
+ source = http://wordnetcode.princeton.edu/wn3.1.dict.tar.gz
+ source = wordnet.desktop
+ source = wordnet.png
+ md5sums = 89b4db7c6840ce69a8e315a3f83d996b
+ md5sums = 072f83df0ca7c387a44dd7ef5b199150
+ md5sums = 0211d836cccb72e8aabe88c5e47a8b1e
+ md5sums = 2c6d64f7d28062944d6969deb8dee9ab
+
+pkgname = wordnet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b308184c475d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Steven Allen <steven {at} stebalien {dot} com>
+# Contributor: Reverie <reverie@takhis.net>
+
+pkgname=wordnet
+pkgver=3.1
+_srcver=3.0
+pkgrel=1
+pkgdesc="An Electronic Lexical Database from Princeton University"
+arch=('i686' 'x86_64')
+url="http://wordnet.princeton.edu/"
+license=("custom")
+options=(staticlibs)
+depends=('tk')
+source=(http://wordnetcode.princeton.edu/${_srcver}/WordNet-${_srcver}.tar.bz2
+ http://wordnetcode.princeton.edu/wn${pkgver}.dict.tar.gz
+ wordnet.desktop
+ wordnet.png)
+md5sums=('89b4db7c6840ce69a8e315a3f83d996b'
+ '072f83df0ca7c387a44dd7ef5b199150'
+ '0211d836cccb72e8aabe88c5e47a8b1e'
+ '2c6d64f7d28062944d6969deb8dee9ab')
+
+build() {
+ cd $srcdir/WordNet-$_srcver
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ sed 's:#define DEFAULTPATH "/usr/dict":#define DEFAULTPATH "/usr/share/wordnet/dict":' -i config.h
+ sed 's:"/usr/local/WordNet-3.0/lib/wnres":"/usr/share/wordnet/wnres":' -i src/wnb
+ make CFLAGS="$CFLAGS -DUSE_INTERP_RESULT"
+}
+
+package() {
+ cd $srcdir/WordNet-$_srcver
+ make DESTDIR=$pkgdir install
+ mv $pkgdir/usr/doc $pkgdir/usr/share/wordnet
+ mv $pkgdir/usr/lib/wnres $pkgdir/usr/share/wordnet/wnres
+ rm -fr $pkgdir/usr/include/tk
+
+ # Replace dictionary files
+ cp -a $srcdir/dict/ $pkgdir/usr/share/wordnet/dict
+ rm -fr $pkgdir/usr/dict
+
+ install -D -m644 $srcdir/wordnet.desktop $pkgdir/usr/share/applications/wordnet.desktop
+ install -D -m644 $srcdir/wordnet.png $pkgdir/usr/share/pixmaps/wordnet.png
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
diff --git a/wordnet.desktop b/wordnet.desktop
new file mode 100644
index 000000000000..ed766b305168
--- /dev/null
+++ b/wordnet.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=WordNet
+Comment=Princeton Dictionary
+Categories=Application;Office;Dictionary
+Icon=/usr/share/pixmaps/wordnet.png
+Exec=wnb
+StartupWMClass=WordNet
+StartupNotify=false
+Terminal=false
+TryExec=wnb
diff --git a/wordnet.png b/wordnet.png
new file mode 100644
index 000000000000..a54d16e0db57
--- /dev/null
+++ b/wordnet.png
Binary files differ