summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Allen2018-09-26 11:52:14 -0700
committerSteven Allen2018-09-26 11:53:02 -0700
commite3340c570a87486c071fa51e8f235542a8ba3c52 (patch)
treed3076ee18c56bfe567ac17226aa4dad0b6b22525
parent351ed124732db65c55ce43e1d217db8b23eb96d9 (diff)
downloadaur-e3340c570a87486c071fa51e8f235542a8ba3c52.tar.gz
split the package into wordnet-{common,cli,tk}
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD58
2 files changed, 67 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22005d751053..cf45fa194607 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = wordnet
- pkgdesc = An Electronic Lexical Database from Princeton University
pkgver = 3.1
- pkgrel = 2
+ pkgrel = 3
url = http://wordnet.princeton.edu/
arch = i686
arch = x86_64
license = custom
- depends = tk
- options = staticlibs
+ makedepends = tk
source = http://wordnetcode.princeton.edu/3.0/WordNet-3.0.tar.bz2
source = http://wordnetcode.princeton.edu/wn3.1.dict.tar.gz
source = wordnet.desktop
@@ -17,5 +15,18 @@ pkgbase = wordnet
sha256sums = 10a4011b3d9705b2b0a1f496b33d926d4be21439c63f039b871d93f2d143ed0c
sha256sums = 9ab9f761a3fabd278fd05d755fec8a403874f899d7e40347f1da48bf93a67e97
-pkgname = wordnet
+pkgname = wordnet-common
+ pkgdesc = An Electronic Lexical Database from Princeton University
+ conflicts = wordnet
+
+pkgname = wordnet-tk
+ pkgdesc = A TK frontend for the WordNet Database
+ depends = wordnet-common
+ conflicts = wordnet
+
+pkgname = wordnet-cli
+ pkgdesc = A CLI fontend for the WordNet Database
+ depends = wordnet-common
+ conflicts = wordnet
+ replaces = wordnet
diff --git a/PKGBUILD b/PKGBUILD
index c054b359e96e..e21ff52597f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Steven Allen <steven {at} stebalien {dot} com>
# Contributor: Reverie <reverie@takhis.net>
-pkgname=wordnet
+pkgbase=wordnet
+pkgname=(wordnet-common wordnet-tk wordnet-cli)
pkgver=3.1
_srcver=3.0
-pkgrel=2
-pkgdesc="An Electronic Lexical Database from Princeton University"
+pkgrel=3
arch=('i686' 'x86_64')
url="http://wordnet.princeton.edu/"
license=("custom")
-options=(staticlibs)
-depends=('tk')
+makedepends=('tk')
source=("http://wordnetcode.princeton.edu/${_srcver}/WordNet-${_srcver}.tar.bz2"
"http://wordnetcode.princeton.edu/wn${pkgver}.dict.tar.gz"
wordnet.desktop
@@ -30,11 +29,23 @@ build() {
make
}
-package() {
+package_wordnet-common() {
+ pkgdesc="An Electronic Lexical Database from Princeton University"
+ conflicts=('wordnet')
+
cd "${srcdir}/WordNet-${_srcver}"
make DESTDIR="$pkgdir" install
+
+ # Remove "binary" stuff.
+ rm -f "${pkgdir}/usr/doc/"{html/*.1WN.html,pdf/*.1.pdf,ps/*.1.ps}
+ rm -fr "${pkgdir}/usr/share/man/man1"
+ rm -fr "${pkgdir}/usr/bin"
+
+ # Move the documentation into place.
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/wordnet"
mv "${pkgdir}/usr/lib/wnres" "${pkgdir}/usr/share/wordnet/wnres"
+
+ # Remove TK library stuff.
rm -fr "${pkgdir}/usr/include/tk"
# Replace dictionary files
@@ -42,7 +53,40 @@ package() {
chmod -R u=rwX,go=rX "${pkgdir}/usr/share/wordnet/dict"
rm -fr "${pkgdir}/usr/dict"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/COPYING"
+}
+
+package_wordnet-tk() {
+ pkgdesc="A TK frontend for the WordNet Database"
+ depends=('tk')
+ conflicts=('wordnet')
+ depends=('wordnet-common')
+
+ cd "${srcdir}/WordNet-${_srcver}"
+
+ # Install the GUI.
+ install -D -m755 -t "${pkgdir}/usr/bin/" src/{wnb,wishwn}
+ install -D -m644 -t "${pkgdir}/usr/share/wordnet/html/" doc/html/wnb.1WN.html
+ install -D -m644 -t "${pkgdir}/usr/share/wordnet/pdf/" doc/pdf/wnb.1.pdf
+ install -D -m644 -t "${pkgdir}/usr/share/wordnet/ps/" doc/ps/wnb.1.ps
+ install -D -m644 -t "${pkgdir}/usr/share/man/man1/" doc/man/wnb.1
+
install -D -m644 "${srcdir}/wordnet.desktop" "${pkgdir}/usr/share/applications/wordnet.desktop"
install -D -m644 "${srcdir}/wordnet.png" "${pkgdir}/usr/share/pixmaps/wordnet.png"
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/COPYING"
+}
+
+package_wordnet-cli() {
+ pkgdesc="A CLI fontend for the WordNet Database"
+ replaces=('wordnet')
+ conflicts=('wordnet')
+ depends=('wordnet-common')
+
+ cd "${srcdir}/WordNet-${_srcver}"
+
+ # Install the CLI.
+ install -D -m755 -t "${pkgdir}/usr/bin/" src/wn
+ install -D -m644 -t "${pkgdir}/usr/share/wordnet/html/" doc/html/wn.1WN.html
+ install -D -m644 -t "${pkgdir}/usr/share/wordnet/pdf/" doc/pdf/wn.1.pdf
+ install -D -m644 -t "${pkgdir}/usr/share/wordnet/ps/" doc/ps/wn.1.ps
+ install -D -m644 -t "${pkgdir}/usr/share/man/man1/" doc/man/wn.1
}