summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2021-04-12 13:20:35 +0000
committerJonas Heinrich2021-04-12 13:20:35 +0000
commit044dbe010bad91a970a052251db06a3d6b259dc9 (patch)
treed3ff79ba64cdeff91560dc12c1aac6833adeca1b
downloadaur-044dbe010bad91a970a052251db06a3d6b259dc9.tar.gz
inital commit at 2.20.12.09
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecc436b677bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wordpress-plugin-async-javascript
+ pkgdesc = Increase the performance of your WordPress website
+ pkgver = 2.20.12.09
+ pkgrel = 1
+ url = https://autoptimize.com
+ arch = any
+ license = GPL2
+ depends = wordpress
+ options = !strip
+ source = wordpress-plugin-async-javascript-2.20.12.09.tar.gz::https://downloads.wordpress.org/plugin/async-javascript.2.20.12.09.zip
+ sha512sums = 288668f888cebb1425d828405a56f187138d095711a110bbfa1c4fb9cb7129621d5fd8da397d1f2f3de41476fb3dbef7daadae3c61bc1cb53d7bdd3f62c1a76a
+
+pkgname = wordpress-plugin-async-javascript
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f7151cb9e9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=wordpress-plugin-async-javascript
+pkgver=2.20.12.09
+pkgrel=1
+pkgdesc="Increase the performance of your WordPress website"
+arch=('any')
+url="https://autoptimize.com"
+license=('GPL2')
+depends=('wordpress')
+makedepends=()
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://downloads.wordpress.org/plugin/async-javascript.${pkgver}.zip")
+sha512sums=('288668f888cebb1425d828405a56f187138d095711a110bbfa1c4fb9cb7129621d5fd8da397d1f2f3de41476fb3dbef7daadae3c61bc1cb53d7bdd3f62c1a76a')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/wordpress/wp-content/plugins"
+ cp -ra "${srcdir}/async-javascript" "${pkgdir}/usr/share/webapps/wordpress/wp-content/plugins/"
+}