summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2019-07-31 12:52:09 +0200
committerJonas Heinrich2019-07-31 12:52:09 +0200
commit00af55532978489817d6126909730a42d5d93a7e (patch)
treeee13912fb3ba43201a54e2e284999c083a9cc8bb
downloadaur-00af55532978489817d6126909730a42d5d93a7e.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..deb098a13164
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wordpress-plugin-code-syntax-block
+ pkgdesc = Extends Gutenberg adding color syntax highlighting to the code block
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/mkaz/code-syntax-block
+ arch = any
+ license = GPL2
+ depends = wordpress
+ options = !strip
+ source = wordpress-plugin-code-syntax-block-1.0.0.tar.gz::https://downloads.wordpress.org/plugin/code-syntax-block.1.0.0.zip
+ sha512sums = 5a07b37668577a4b0af691c0b1ced39039a3ea80b45526dc69472f75b01b758106051af04571cd3dd0161574684956539857a08aa0657514af1ac3fc581d6f8e
+
+pkgname = wordpress-plugin-code-syntax-block
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ca57460bfbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=wordpress-plugin-code-syntax-block
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Extends Gutenberg adding color syntax highlighting to the code block"
+arch=('any')
+url="https://github.com/mkaz/code-syntax-block"
+license=('GPL2')
+depends=('wordpress')
+makedepends=()
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://downloads.wordpress.org/plugin/code-syntax-block.${pkgver}.zip")
+sha512sums=("5a07b37668577a4b0af691c0b1ced39039a3ea80b45526dc69472f75b01b758106051af04571cd3dd0161574684956539857a08aa0657514af1ac3fc581d6f8e")
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/wordpress/wp-content/plugins"
+ cp -ra "${srcdir}/code-syntax-block" "${pkgdir}/usr/share/webapps/wordpress/wp-content/plugins/"
+}