summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2019-07-31 13:23:21 +0200
committerJonas Heinrich2019-07-31 13:23:21 +0200
commit31c43e0903e9745ce9598c12d49d8c030986aeaf (patch)
treee39ed2ece02d89c867a407b7a9cfdd03dc3da644
downloadaur-31c43e0903e9745ce9598c12d49d8c030986aeaf.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06b71d19e145
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wordpress-plugin-wp-statistics
+ pkgdesc = Anti spam plugin
+ pkgver = 12.6.7
+ pkgrel = 1
+ url = https://github.com/wp-statistics/wp-statistics
+ arch = any
+ license = GPL3
+ depends = wordpress
+ options = !strip
+ source = wordpress-plugin-wp-statistics-12.6.7.tar.gz::https://downloads.wordpress.org/plugin/wp-statistics.12.6.7.zip
+ sha512sums = 436d188ee1fdcada584a89c85858ae37311568b52c77b0c8936d786df8984ffc0beaf70dff8a27624b050ef29c5e0c80c8bf837ddefcb72cf578a463aaf02569
+
+pkgname = wordpress-plugin-wp-statistics
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22f84f8840db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=wordpress-plugin-wp-statistics
+pkgver=12.6.7
+pkgrel=1
+pkgdesc="Anti spam plugin"
+arch=('any')
+url="https://github.com/wp-statistics/wp-statistics"
+license=('GPL3')
+depends=('wordpress')
+makedepends=()
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://downloads.wordpress.org/plugin/wp-statistics.${pkgver}.zip")
+sha512sums=("436d188ee1fdcada584a89c85858ae37311568b52c77b0c8936d786df8984ffc0beaf70dff8a27624b050ef29c5e0c80c8bf837ddefcb72cf578a463aaf02569")
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/wordpress/wp-content/plugins"
+ cp -ra "${srcdir}/wp-statistics" "${pkgdir}/usr/share/webapps/wordpress/wp-content/plugins/"
+ install -D "${srcdir}/wp-statistics/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}