summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenuks2017-08-05 11:48:19 +0200
committerfenuks2017-08-05 11:48:19 +0200
commit81ae7b290061e28f5263568cdfad7ea7e67d0600 (patch)
treea9751e04a406cf54258e9b59e65e0434bfc97b77
downloadaur-81ae7b290061e28f5263568cdfad7ea7e67d0600.tar.gz
Initial release; version 20170729-1
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD29
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6e8fd4a8f27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Aug 5 09:46:36 UTC 2017
+pkgbase = words-pl
+ pkgdesc = A ‘words’ file for Polish language
+ pkgver = 20170729
+ pkgrel = 1
+ url = https://sjp.pl/slownik/odmiany/
+ arch = any
+ license = GPL
+ license = LGPL
+ license = Apache
+ license = CCPL
+ makedepends = dos2unix
+ conflicts = words-pl
+ source = https://sjp.pl/slownik/odmiany/sjp-odm-20170729.zip
+ md5sums = 3b85dfeeeecb7ead69124e2e5367b8bb
+ sha256sums = f9bdb5cee88e755d2c35c9f2f11510bee3317e3a3dda0e302b1feb959c03fd66
+
+pkgname = words-pl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..69d3410df605
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.tar
+*.tar.xz
+*.tar.gz
+*.zip
+pkg/
+src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bd03c1a9387
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: fenuks
+# TODO: check if using https://sjp.pl/slownik/ort/ won't be better idea
+
+pkgname=words-pl
+pkgver=20170729
+pkgrel=1
+pkgdesc="A ‘words’ file for Polish language"
+arch=("any")
+url="https://sjp.pl/slownik/odmiany/"
+license=("GPL" "LGPL" "Apache" "CCPL")
+depends=()
+optdepends=()
+makedepends=("dos2unix")
+conflicts=("${pkgname}")
+# install=$pkgname.install
+source=("https://sjp.pl/slownik/odmiany/sjp-odm-${pkgver}.zip")
+md5sums=('3b85dfeeeecb7ead69124e2e5367b8bb')
+sha256sums=('f9bdb5cee88e755d2c35c9f2f11510bee3317e3a3dda0e302b1feb959c03fd66')
+
+build() {
+ cd "${srcdir}"
+ grep -v '^\?' odm.txt | sed 's/, /\n/g' > polish
+ dos2unix polish
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm644 polish "$pkgdir/usr/share/dict/polish"
+}