summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2015-06-12 15:38:27 +0200
committerSteffen Weber2015-06-12 15:38:27 +0200
commitfb2db1cc32165b1fb87ac7bcad51cfa3a2ec7d63 (patch)
tree161611dba3dc43110817b4b90954a72111b146ac
downloadaur-fb2db1cc32165b1fb87ac7bcad51cfa3a2ec7d63.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--wordwarvi.desktop11
-rw-r--r--wordwarvi.install11
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f0634e9705c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wordwarvi
+ pkgdesc = Side-scrolling shoot 'em up '80s style arcade game
+ pkgver = 1.00
+ pkgrel = 2
+ url = http://wordwarvi.sourceforge.net
+ install = wordwarvi.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = custom
+ depends = gtk2
+ depends = portaudio
+ source = https://downloads.sourceforge.net/wordwarvi/wordwarvi-1.00.tar.gz
+ source = wordwarvi.desktop
+ md5sums = 034a908346a2ab514f92b12f5e952b80
+ md5sums = ab6a905ec749940057a3816a833f103b
+
+pkgname = wordwarvi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9306345979cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Christopher Rogers <slaxemulator@gmail.com>
+# Contributor: J. W. Birdsong <jwbirdsong AT gmail DOT com>
+
+pkgname=wordwarvi
+pkgver=1.00
+pkgrel=2
+pkgdesc="Side-scrolling shoot 'em up '80s style arcade game"
+arch=('i686' 'x86_64')
+url="http://$pkgname.sourceforge.net"
+license=('GPL2' 'custom')
+depends=('gtk2' 'portaudio')
+install=$pkgname.install
+source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname.desktop)
+md5sums=('034a908346a2ab514f92b12f5e952b80'
+ 'ab6a905ec749940057a3816a833f103b')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i "s,sounds/,/usr/share/$pkgname/sounds/," $pkgname.c
+}
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 sounds/Attribution.txt $pkgdir/usr/share/licenses/$pkgname/COPYING_SOUNDS
+ install -Dm644 ../$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 icons/wordwarvi_icon_48x48.png $pkgdir/usr/share/pixmaps/$pkgname.png
+
+ for _width in '16' '22' '32' '48' '64' '128'; do
+ install -Dm644 icons/${pkgname}_icon_${_width}x${_width}.png \
+ $pkgdir/usr/share/icons/hicolor/${_width}x${_width}/apps/$pkgname.png
+ done
+} \ No newline at end of file
diff --git a/wordwarvi.desktop b/wordwarvi.desktop
new file mode 100644
index 000000000000..34389bcd9fb9
--- /dev/null
+++ b/wordwarvi.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Type=Application
+Name=Word War Vi
+Comment=A side-scrolling shoot 'em up '80s style arcade game
+Exec=wordwarvi
+Icon=wordwarvi
+Categories=Game;Arcade;
+Terminal=false
+StartupNotify=false
diff --git a/wordwarvi.install b/wordwarvi.install
new file mode 100644
index 000000000000..a2930a4ff27b
--- /dev/null
+++ b/wordwarvi.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}