summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-06-11 09:11:33 -0600
committerMark Wagie2022-06-11 09:11:33 -0600
commit063ebb7e45a944e430c0910709bffe9206b917ed (patch)
treef43e41f63d07fc1bde7c2b248a373ffc1db52f40
parent06bdd7b1809889e8d54f2998ce6df7b4301775e6 (diff)
downloadaur-063ebb7e45a944e430c0910709bffe9206b917ed.tar.gz
Install scalable action icons to doc folder so they can be copied to user space for use
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
-rw-r--r--workbench.install9
4 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80ebac4d020d..35d7a36c9271 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = workbench
pkgdesc = Learn and prototype with GNOME technologies
pkgver = 42.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sonnyp/Workbench
+ install = workbench.install
arch = x86_64
license = GPL3
checkdepends = appstream-glib
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..e3598ecb9d55 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!workbench.install
diff --git a/PKGBUILD b/PKGBUILD
index 2ebdbc031d9d..829950d834cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=workbench
pkgver=42.0
-pkgrel=1
+pkgrel=2
pkgdesc="Learn and prototype with GNOME technologies"
arch=('x86_64')
url="https://github.com/sonnyp/Workbench"
@@ -14,6 +14,7 @@ checkdepends=('appstream-glib')
optdepends=('gtk4-demos: GTK Demo, GTK Widget Factory, GTK Icon Browser'
'highlight: syntax highlighting'
'libadwaita-demos: Adwaita Demo')
+install="$pkgname.install"
_commit=b86cdfb3e6440e4e034fcb6c609ff84401630faa
source=("git+https://github.com/sonnyp/Workbench.git#commit=${_commit}"
'git+https://gitlab.gnome.org/Teams/Design/icon-development-kit-www.git'
@@ -55,6 +56,9 @@ package() {
cd "$srcdir/Workbench"
meson install -C build --destdir "$pkgdir"
- # Some icons conflict with other packages like Geary and Extension Manager
- rm -rf "$pkgdir/usr/share/icons/hicolor/scalable/actions/"
+ # Scalable action icons conflict with numerous other packages
+ # Install to doc folder so they can be copied to user space for use
+ install -d "$pkgdir/usr/share/doc/$pkgname/icons/hicolor/scalable"
+ mv "$pkgdir/usr/share/icons/hicolor/scalable/actions" \
+ "$pkgdir/usr/share/doc/$pkgname/icons/hicolor/scalable/"
}
diff --git a/workbench.install b/workbench.install
new file mode 100644
index 000000000000..90ec5261a12f
--- /dev/null
+++ b/workbench.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Install scalable action icons locally:"
+ echo ""
+ echo "cp -f /usr/share/doc/workbench/icons/ ~/.local/share/"
+}
+
+post_upgrade() {
+ post_install
+}