summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-05-12 09:56:56 -0600
committerMark Wagie2022-05-12 09:56:56 -0600
commit089e24d64ee6e0111d58e1f9117a1aa4c45f151a (patch)
tree31420e249c3eb86e50215dafe74403653a76871d
parentc714c7730be9acedd7e5a6cfeda54db5412e3fa2 (diff)
downloadaur-089e24d64ee6e0111d58e1f9117a1aa4c45f151a.tar.gz
fixes and improvements
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD43
-rwxr-xr-xworkbench3
-rw-r--r--workbench.desktop10
5 files changed, 48 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e315693d584..ee1aa1c53d19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,25 @@
pkgbase = workbench
pkgdesc = Learn and prototype with GNOME technologies
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sonnyp/Workbench
- arch = x86_64
+ arch = any
license = GPL3
checkdepends = appstream-glib
makedepends = git
makedepends = meson
- depends = libadwaita
- depends = glib2
- depends = gtksourceview5
+ makedepends = npm
depends = gjs
- depends = vte4-git
+ depends = gtksourceview5
+ depends = libadwaita
depends = libportal-gtk4
- source = https://github.com/sonnyp/Workbench/archive/v1.2.0.tar.gz
- b2sums = b9e5382d6175a134d7bac570e44b3304fdc010f6d26c38a040d23a137742c858597f57dcf5649a82a105bc3fd0c0abc0cc7941a33fe007f67ee16eb25140f8f0
+ depends = vte4-git
+ optdepends = gtk4-demos: GTK Demo, GTK Widget Factory, GTK Icon Browser
+ optdepends = highlight: syntax highlighting
+ optdepends = libadwaita-demos: Adwaita Demo
+ source = git+https://github.com/sonnyp/Workbench.git#tag=v1.2.0
+ source = git+https://github.com/sonnyp/troll.git
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = workbench
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 3ee8e1d87732..424071390e57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,48 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=workbench
-_pkgname=Workbench
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Learn and prototype with GNOME technologies"
-arch=('x86_64')
+arch=('any')
url="https://github.com/sonnyp/Workbench"
license=('GPL3')
-depends=('libadwaita' 'glib2' 'gtksourceview5' 'gjs' 'vte4-git' 'libportal-gtk4')
-makedepends=('git' 'meson')
+depends=('gjs' 'gtksourceview5' 'libadwaita' 'libportal-gtk4' 'vte4-git')
+makedepends=('git' 'meson' 'npm')
checkdepends=('appstream-glib')
-source=($url/archive/v$pkgver.tar.gz)
-b2sums=('b9e5382d6175a134d7bac570e44b3304fdc010f6d26c38a040d23a137742c858597f57dcf5649a82a105bc3fd0c0abc0cc7941a33fe007f67ee16eb25140f8f0')
+optdepends=('gtk4-demos: GTK Demo, GTK Widget Factory, GTK Icon Browser'
+ 'highlight: syntax highlighting'
+ 'libadwaita-demos: Adwaita Demo')
+source=("git+https://github.com/sonnyp/Workbench.git#tag=v$pkgver"
+ 'git+https://github.com/sonnyp/troll.git')
+sha256sums=('SKIP'
+ 'SKIP')
prepare() {
- cd "$_pkgname-$pkgver"
- git submodule init
- git submodule update
- sed -i 's/\/app\//\/usr\//' src/re.sonny.Workbench
+ cd "$srcdir/Workbench"
+ git submodule init
+ git config submodule.src/troll.url "$srcdir/troll"
+ git submodule update
+
+ sed -i 's|app/share|usr/share|g' src/re.sonny.Workbench
}
build() {
- arch-meson "$_pkgname-$pkgver" build
+ cd "$srcdir/Workbench"
+ export npm_config_cache="$srcdir/npm_cache"
+ npm install
+
+ arch-meson . build
meson compile -C build
}
-#check() {
-# meson test -C build
-#}
+check() {
+ cd "$srcdir/Workbench"
+ meson test -C build --print-errorlogs || :
+}
package() {
+ cd "$srcdir/Workbench"
meson install -C build --destdir "$pkgdir"
}
diff --git a/workbench b/workbench
deleted file mode 100755
index 5f5536bc80f1..000000000000
--- a/workbench
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-_pyver=`python2 -V 2>&1|sed -e 's/.* 2\.\([0-9]\).*/\1/'`
-python2 /usr/lib/python2.${_pyver}/site-packages/workbench/wb_main.py
diff --git a/workbench.desktop b/workbench.desktop
deleted file mode 100644
index 09c1125b3df9..000000000000
--- a/workbench.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=Work Bench
-Comment=Python Subversion Client
-Exec=workbench
-Icon=wb
-Terminal=false
-Type=Application
-Categories=GNOME;Application;Development;
-StartupNotify=false