summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomek Łaziuk2016-03-25 12:54:39 +0100
committerTomek Łaziuk2016-03-25 12:54:39 +0100
commitc309ce7ee31ab3412d87b35e736c437de68ca7f7 (patch)
tree52e5a1699ba94c648eea4643eeccdf572146d7b6
parent3fc62607f5eb6f71e252995d39f3a4349077e145 (diff)
downloadaur-c309ce7ee31ab3412d87b35e736c437de68ca7f7.tar.gz
permissions
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1fb87541b72..d4f0c16a9245 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = worksnaps
pkgdesc = Time Tracking with Screenshots for Remote Teams
pkgver = 1.1.20150618
- pkgrel = 1
+ pkgrel = 2
url = http://www.worksnaps.com/www/download.shtml
arch = any
license = unknown
diff --git a/PKGBUILD b/PKGBUILD
index 494250fd6aee..0408de5b2ee3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=worksnaps
pkgver=1.1.20150618
-pkgrel=1
+pkgrel=2
pkgdesc="Time Tracking with Screenshots for Remote Teams"
arch=('any')
url="http://www.worksnaps.com/www/download.shtml"
@@ -12,6 +12,7 @@ source=("http://worksnaps-download.s3.amazonaws.com/WSClient-linux-$pkgver.zip")
md5sums=('7bc4f74ac3d7ed0e889172596c32eff7')
prepare() {
+ # the main executable file
src='#!/usr/bin/env sh
path="/usr/lib/worksnaps/bin/run.sh"
script=$(realpath "$path")
@@ -19,7 +20,11 @@ cd $(dirname "$script")
exec "$script"'
filename="$srcdir/worksnaps"
echo "$src" > "$filename"
- chmod a+x "$filename"
+ chmod a+rx "$filename"
+ # make sure everybody has access to the files
+ chmod a+r "$srcdir" --recursive
+ # worksnaps requires write access to the sh filesi, thats unsafe but otherwise an java exception is thrown
+ find "$srcdir" -type f -name "*.sh" -exec chmod a+rwx {} \;
}
package() {