summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Printzell2015-12-27 23:35:40 +0100
committerDan Printzell2015-12-27 23:35:40 +0100
commit6f37f09ce0cd20bd0f4f747a069bad92a1099555 (patch)
tree176b1315ff4b8565d431a1f738ac0a0e15b9f401
downloadaur-6f37f09ce0cd20bd0f4f747a069bad92a1099555.tar.gz
Imported base from workspace-d-git
Signed-off-by: Dan Printzell <xwildn00bx@gmail.com>
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD40
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a3fbbb38086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 22:34:45 UTC 2015
+pkgbase = workspace-d
+ pkgdesc = Wraps dcd, dfmt and dscanner to one unified environment managed by dub
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/Pure-D/workspace-d
+ arch = i686
+ arch = x86_64
+ groups = dlang
+ license = MIT
+ makedepends = dmd
+ makedepends = git
+ makedepends = dub
+ depends = libphobos
+ depends = dub
+ depends = dcd
+ depends = dfmt
+ depends = dscanner
+ provides = workspace-d
+ conflicts = workspace-d
+ source = git+https://github.com/Pure-D/workspace-d#tag=v1.1.0
+ sha256sums = SKIP
+
+pkgname = workspace-d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d87e6f06d62a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Dan Printzell <me@vild.io>
+
+pkgname=('workspace-d')
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Wraps dcd, dfmt and dscanner to one unified environment managed by dub"
+arch=('i686' 'x86_64')
+url="https://github.com/Pure-D/workspace-d"
+license=("MIT")
+groups=('dlang')
+makedepends=('dmd' 'git' 'dub')
+depends=('libphobos' 'dub' 'dcd' 'dfmt' 'dscanner')
+provides=('workspace-d')
+conflicts=('workspace-d')
+
+source=(
+ "git+https://github.com/Pure-D/workspace-d#tag=v1.1.0"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+prepare() {
+ cd $srcdir/workspace-d
+ git submodule update --init --recursive
+}
+
+build() {
+ cd $srcdir/workspace-d
+ dub build
+ strip workspace-d
+}
+
+package(){
+ cd $srcdir/workspace-d
+
+ # binaries
+ mkdir -p $pkgdir/usr/bin
+ install -m755 -t $pkgdir/usr/bin ./workspace-d
+}