summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Costa2024-08-02 22:10:07 +0200
committerJonas Costa2024-08-02 22:10:07 +0200
commitc8d6d112b86961d501e1cf9bc9597232a1109eb4 (patch)
treede394c763896ce591f83535cd2cd0a6ad12ca799
parente73cd4a625f66417555eacab28fe01457ae4b0a5 (diff)
downloadaur-c8d6d112b86961d501e1cf9bc9597232a1109eb4.tar.gz
Add PKGBUILD and sources
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
-rw-r--r--world-of-goo-2.desktop9
-rw-r--r--world-of-goo-2.pngbin0 -> 239669 bytes
4 files changed, 36 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 5d2967ffe538..385ffc687311 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,4 @@
!.SRCINFO
!.gitignore
!world-of-goo-2.desktop
-!icon.png
+!world-of-goo-2.png
diff --git a/PKGBUILD b/PKGBUILD
index e69de29bb2d1..e74d22ac0cb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jonas Costa <contact@jonascosta.ch>
+pkgname=world-of-goo-2
+pkgver=12329.171
+pkgrel=1
+pkgdesc="Build bridges, grow towers, terraform terrain, and fuel flying machines in the followup to World of Goo."
+arch=("x86_64")
+url="https://worldofgoo2.com"
+license=('custom')
+depends=()
+source=("world-of-goo-2.desktop" "world-of-goo-2.png" "World_of_Goo_2-x86_64.12329.171.AppImage")
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/512x512/apps"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ chmod +x "$srcdir/World_of_Goo_2-x86_64.$pkgver.AppImage"
+ cp -r "$srcdir/World_of_Goo_2-x86_64.$pkgver.AppImage" "$pkgdir/usr/bin/$pkgname"
+
+ cp "$srcdir/world-of-goo-2.desktop" "$pkgdir/usr/share/applications/world-of-goo-2.desktop"
+ cp "$srcdir/world-of-goo-2.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/world-of-goo-2.png"
+}
+
+sha256sums=('bdbccb2818a242beb073d2d47e62b7852a5655ab83fb347f8b23b51bfff9d282'
+ '54ef5f65d8ad932bbe1e3d8431002ba7e9cc16d366bbfc33ef67b6eaee1e0614'
+ 'fdd39d7abdf7de5aa02a2f9d402233795b4f39b458b27e4b49895d5c55da2bca')
diff --git a/world-of-goo-2.desktop b/world-of-goo-2.desktop
index e69de29bb2d1..d64be77facd6 100644
--- a/world-of-goo-2.desktop
+++ b/world-of-goo-2.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=World of Goo 2
+Comment=Physics-based puzzle game
+Exec=/usr/bin/world-of-goo-2 %U
+Icon=world-of-goo-2
+Terminal=false
+Type=Application
+Categories=Game;
+
diff --git a/world-of-goo-2.png b/world-of-goo-2.png
new file mode 100644
index 000000000000..1909054929d4
--- /dev/null
+++ b/world-of-goo-2.png
Binary files differ