summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeromy Reimer2015-06-27 11:35:55 -0600
committerJeromy Reimer2015-06-27 11:35:55 -0600
commitb0562cce8fa05a0a7cf434159e557447a6c3230f (patch)
treed5cb76fe96a542159d8d45c531b98849c858ec38
downloadaur-b0562cce8fa05a0a7cf434159e557447a6c3230f.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
-rwxr-xr-xWorldEditor.desktop20
-rw-r--r--WorldEditor.pngbin0 -> 54784 bytes
-rw-r--r--worldeditor.install17
5 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..247d6a571cb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = worldeditor-bin
+ pkgdesc = WorldEditor (WED) is a CAD-like graphic editor that lets you create custom airport layouts. It is designed for X-Plane, and works with apt.dat version 850 and higher.
+ pkgver = 1.3.1r1
+ pkgrel = 1
+ url = http://developer.x-plane.com/tools/worldeditor/
+ install = worldeditor.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libcurl-compat
+ source = http://dev.x-plane.com/download/tools/wed_lin_131r1.zip
+ source = WorldEditor.desktop
+ source = WorldEditor.png
+ md5sums = 31726a624f7d56624f5a6fb729317651
+ md5sums = 39c0422577f37dcf489787a5a6b52830
+ md5sums = 0efb061145dcfec118afcc6ffff044f1
+
+pkgname = worldeditor-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0815bb7df8c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: nic96
+pkgname=worldeditor-bin
+pkgver=1.3.1r1
+pkgrel=1
+pkgdesc="WorldEditor (WED) is a CAD-like graphic editor that lets you create custom airport layouts. It is designed for X-Plane, and works with apt.dat version 850 and higher."
+url="http://developer.x-plane.com/tools/worldeditor/"
+license=('GPL')
+install='worldeditor.install'
+arch=('i686' 'x86_64')
+depends=('libcurl-compat')
+source=("http://dev.x-plane.com/download/tools/wed_lin_131r1.zip"
+ "WorldEditor.desktop"
+ "WorldEditor.png")
+md5sums=('31726a624f7d56624f5a6fb729317651'
+ '39c0422577f37dcf489787a5a6b52830'
+ '0efb061145dcfec118afcc6ffff044f1')
+
+package() {
+ cd "${srcdir}/"
+ install -Dm755 "$srcdir"/WED "$pkgdir"/usr/bin/WED
+ install -Dm644 "$srcdir"/WorldEditor.desktop "$pkgdir"/usr/share/applications/WorldEditor.desktop
+ install -Dm644 "$srcdir"/WorldEditor.png "$pkgdir"/usr/share/pixmaps/WorldEditor.png
+}
diff --git a/WorldEditor.desktop b/WorldEditor.desktop
new file mode 100755
index 000000000000..d728e20d8d18
--- /dev/null
+++ b/WorldEditor.desktop
@@ -0,0 +1,20 @@
+[Desktop Entry]
+Comment[en_US]=WorldEditor (WED) is a CAD-like graphic editor that lets you create custom airport layouts. It is designed for X-Plane, and works with apt.dat version 850 and higher.
+Comment=WorldEditor (WED) is a CAD-like graphic editor that lets you create custom airport layouts. It is designed for X-Plane, and works with apt.dat version 850 and higher.
+Exec=LD_PRELOAD=libcurl.so.3 WED
+GenericName[en_US]=Airport Layout Creator
+GenericName=Airport Layout Creator
+Icon=WorldEditor
+MimeType=
+Name[en_US]=WorldEditor
+Name=WorldEditor
+Path=
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
+Categories=Game;Simulation;
diff --git a/WorldEditor.png b/WorldEditor.png
new file mode 100644
index 000000000000..9838597a2b16
--- /dev/null
+++ b/WorldEditor.png
Binary files differ
diff --git a/worldeditor.install b/worldeditor.install
new file mode 100644
index 000000000000..e450a48aec2e
--- /dev/null
+++ b/worldeditor.install
@@ -0,0 +1,17 @@
+post_install() {
+echo $'
+X-Plane itself does not need to be installed before using WED. However, WED will require that you choose the X-Plane folder before it will allow you to do anything. Create a working directory with the following structure before starting WED for the first time.
+
+working directory <-- Pick a name
+ |--Custom Scenery
+ |--Global Scenery
+ |--Resources
+ |--default scenery
+
+NOTICE: WED looks for this specific directory structure and specific directory names !
+
+Click "Choose X-Plane folder". Select the working directory for the X-Plane folder.
+'
+echo "To execute this application from terminal use the following command \"LD_PRELOAD=libcurl.so.3 WED\""
+echo
+}