summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:39:06 +0200
committerSanskritFritz2015-06-14 00:39:06 +0200
commitd8a372a5b9e03cbc29579e7ad77ad802c9de03b0 (patch)
treedc2a073410ffcff45e86da7630660e1bcfc089a2
downloadaur-d8a372a5b9e03cbc29579e7ad77ad802c9de03b0.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD78
2 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f03ada16c075
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = worldofpadman-beta
+ pkgdesc = Cartoon-style multiplayer first-person shooter
+ pkgver = 1.5.4
+ pkgrel = 1
+ url = http://www.worldofpadman.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = unzip
+ depends = curl
+ depends = libogg
+ depends = libvorbis
+ depends = mesa
+ depends = openal
+ depends = sdl
+ conflicts = worldofpadman
+ source = wop-1.5-unified.zip::http://sourceforge.net/projects/worldofpadman/files/v1.5/wop-1.5-unified.zip/download
+ source = wop-1.5.x-to-1.5.4-beta-patch.zip::http://sourceforge.net/projects/worldofpadman/files/v1.5/wop-1.5.x-to-1.5.4-beta-patch.zip
+ md5sums = 8871affc2a36f23aa22044454c834923
+ md5sums = 9ff94e1b93ef8e3b4894f5872c535336
+
+pkgname = worldofpadman-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d82aff13e712
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: Jason Melton <jason.melton@gmail.com>
+# Contributor: Tiago Pierezan Camargo <tcamargo@gmail.com>
+# Contributor: Paul Bredbury <brebs@sent.com>
+# Contributor: Benjamin Dirks <asaru[at]wtnet[dot]de>
+
+pkgname=worldofpadman-beta
+pkgver=1.5.4
+pkgrel=1
+pkgdesc="Cartoon-style multiplayer first-person shooter"
+arch=(i686 x86_64)
+url="http://www.worldofpadman.com/"
+license=('GPL' 'custom')
+depends=('curl' 'libogg' 'libvorbis' 'mesa' 'openal' 'sdl')
+makedepends=('unzip')
+conflicts=('worldofpadman')
+source=(
+ wop-1.5-unified.zip::http://sourceforge.net/projects/worldofpadman/files/v1.5/wop-1.5-unified.zip/download
+ wop-1.5.x-to-1.5.4-beta-patch.zip::http://sourceforge.net/projects/worldofpadman/files/v1.5/wop-1.5.x-to-1.5.4-beta-patch.zip
+ )
+
+_gamedir="/usr/share/$pkgname"
+
+build() {
+
+ cd "$srcdir"
+
+ ## Binaries
+ if [ "$CARCH" == i686 ] ; then
+ install -D -m755 wop.i386 "$pkgdir/$_gamedir/wop.bin" || return 1
+ install -D -m755 wopded.i386 "$pkgdir/$_gamedir/wopded.bin" || return 1
+ fi
+
+ if [ "$CARCH" == x86_64 ] ; then
+ install -D -m755 wop.x86_64 "$pkgdir/$_gamedir/wop.bin" || return 1
+ install -D -m755 wopded.x86_64 "$pkgdir/$_gamedir/wopded.bin" || return 1
+ fi
+
+ cat >wop.sh <<EOF
+#!/bin/bash
+cd $_gamedir && exec ./wop.bin "\$@"
+EOF
+ cat >wopded.sh <<EOF
+#!/bin/bash
+cd $_gamedir && exec ./wopded.bin "\$@"
+EOF
+
+ install -D -m755 wop.sh "$pkgdir/usr/bin/wop" || return 1
+ install -D -m755 wopded.sh "$pkgdir/usr/bin/wopded" || return 1
+
+ # Data
+ # Using "read", so can handle filenames containing spaces
+ find wop -type f | while read _f ; do
+ install -D -m644 "$_f" "${pkgdir}/$_gamedir/$_f" || return 1
+ done
+ # Return from the function, since install's return just exits the loop
+ # See http://fvue.nl/wiki/Bash:_Error_handling
+ [ $? -gt 0 ] && return 1
+
+ # Desktop
+ #install -D -m644 ${srcdir}/wop.png ${pkgdir}/usr/share/pixmaps/$pkgname.png || return 1
+ #install -D -m644 ${srcdir}/$pkgname.desktop ${pkgdir}/usr/share/applications/$pkgname.desktop || return 1
+
+ # Docs
+ cd "$srcdir/XTRAS" || return 1
+ # Using "read", so can handle filenames containing spaces
+ find . -type f | while read _f ; do
+ install -D -m644 "$_f" "${pkgdir}/usr/share/doc/$pkgname/$_f" || return 1
+ done
+ # Return from the function, since install's return just exits the loop
+ # See http://fvue.nl/wiki/Bash:_Error_handling
+ [ $? -gt 0 ] && return 1
+
+ # License
+ install -D -m644 copyright_en.txt "${pkgdir}/usr/share/licenses/$pkgname/COPYING" || return 1
+}
+
+md5sums=('8871affc2a36f23aa22044454c834923'
+ '9ff94e1b93ef8e3b4894f5872c535336')