summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerdii2021-05-25 13:13:28 +0200
committererdii2021-05-25 13:13:28 +0200
commitfaffc378f8632d009ba92a305c4e9d6e198dac54 (patch)
tree4231a0c43605998bfc85719add340fb57ca84ecd
downloadaur-faffc378f8632d009ba92a305c4e9d6e198dac54.tar.gz
v2.2.2
Signed-off-by: erdii <me@erdii.engineering>
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--Makefile4
-rw-r--r--PKGBUILD17
4 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a4ff96ce49b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = wormhole-gui-bin
+ pkgdesc = Cross-platform application for easy encrypted sharing of files, folders, and text between devices.
+ pkgver = 2.2.2
+ pkgrel = 1
+ url = https://github.com/Jacalz/wormhole-gui
+ arch = x86_64
+ license = GPLv3
+ source = wormhole-gui-bin-2.2.2.tar.gz::https://github.com/Jacalz/wormhole-gui/releases/download/v2.2.2/wormhole-gui-v2.2.2-linux-amd64.tar.gz
+ sha256sums = 016a0ea6e2975b1ab253c3415c858c4bc2940f344b873cf2f0edff9dabbe7032
+
+pkgname = wormhole-gui-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5de36738dc18
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.gz
+*.tar.gz.part
+*.tar.zst
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..0505b660189d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+update:
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+.PHONY: update
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef0a12ccd08b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: erdii <me@erdii.engineering
+
+pkgname=wormhole-gui-bin
+pkgver=2.2.2
+pkgrel=1
+pkgdesc="Cross-platform application for easy encrypted sharing of files, folders, and text between devices."
+url="https://github.com/Jacalz/wormhole-gui"
+license=('GPLv3')
+arch=('x86_64')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Jacalz/wormhole-gui/releases/download/v${pkgver}/wormhole-gui-v${pkgver}-linux-amd64.tar.gz")
+sha256sums=('016a0ea6e2975b1ab253c3415c858c4bc2940f344b873cf2f0edff9dabbe7032')
+
+package() {
+ install -Dm755 "${srcdir}/usr/local/bin/wormhole-gui" "${pkgdir}/usr/bin/wormhole-gui"
+ install -Dm644 "${srcdir}/usr/local/share/pixmaps/wormhole-gui.png" "${pkgdir}/usr/share/pixmaps/wormhole-gui.png"
+ install -Dm644 "${srcdir}/usr/local/share/applications/wormhole-gui.desktop" "${pkgdir}/usr/share/applications/wormhole-gui.desktop"
+}