summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinay S Shastry2019-12-31 11:47:45 +0530
committerVinay S Shastry2019-12-31 11:47:45 +0530
commitcdd9323a763d0dd57efb40ca10dd37bd45a6e00a (patch)
tree733970f4f6a66a065cc74bf0a75f2550478e7395
downloadaur-cdd9323a763d0dd57efb40ca10dd37bd45a6e00a.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..072c383d313b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wormhole-william
+ pkgdesc = A go (golang) implementation of magic wormhole. It provides secure end-to-end encrypted file transfers between computers. It is compatible with the official python magic wormhole cli tool (see magic-wormhole package).
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/psanford/wormhole-william
+ arch = x86_64
+ license = MIT
+ makedepends = go-pie
+ makedepends = git
+ depends = glibc
+ source = https://github.com/psanford/wormhole-william/archive/v1.0.1.tar.gz
+ sha256sums = c16469855f32689f5cc195db32f43a6f41de06e3d4e7773e38f2c791b7a9fe22
+
+pkgname = wormhole-william
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04c3aa532390
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Vinay Shastry <vinayshastry at gmail dot com>
+
+pkgname=wormhole-william
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='A go (golang) implementation of magic wormhole. It provides secure end-to-end encrypted file transfers between computers. It is compatible with the official python magic wormhole cli tool (see magic-wormhole package).'
+arch=('x86_64')
+url="https://github.com/psanford/${pkgname}"
+license=('MIT')
+depends=('glibc')
+makedepends=('go-pie' 'git')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('c16469855f32689f5cc195db32f43a6f41de06e3d4e7773e38f2c791b7a9fe22')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ go build \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ -gcflags "all=-trimpath=${PWD}" \
+ -asmflags "all=-trimpath=${PWD}" \
+ -o "${pkgname}" .
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 -t "${pkgdir}/usr/bin/" "${pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" LICENSE
+}